Initial setting up of raspberry 3b headless

Hi James, I decided that I would start again and clear the SD card and reload raspbian. This time when running the imager I got a message “error removing existing partitions”. Is there an easy fix to this? NB. I have saved the folder “overlays” onto my hard disk - just in case!

Thanks

Hi Lester,

Usually for this one you can either use the SD Formatter tool, or head into Disk Management (on windows) and remove the partitions from there.

Let me know how this goes and make sure you don’t remove any partitions on your local drives!
-James

1 Like

I’ll do that. Presumably I have to reinstall the “overlay” folder after the SD is wiped?

2 Likes

Answered my own question. The Overlay folder re-appeared after instaling raspbian.

2 Likes

Sorry guys, I’ve run into a brick wall here. I’ve wiped the SD card again, reinstalled raspbian and still get “host not found” message, including with raspberrypi.local and on a blank entry. When I enter the IP address I get a putty window but says it is inactive and an error message “connection refused”.

Sorry to say but my skills don’t run to using nmap or the suggestion about " running ifconfig on your Pi, and in the wlan0 section which is printed to your terminal window grab the ipv4 address (i.e. the IP address for the Pi on the local network)".
Thanks anyway. Cheers

Hi Lester,

Connection Refused Usually means PuTTY could reach the Pi, but was refused connection on the SSH port (22). You must place a file named ssh (no extension) into the boot partition of your pi (the one accessible from windows, in order to enable ssh and open the port.

This is covered in our guide to headless Pi use if you need some clarification:

Keen to see how you go!
-James

1 Like

Thanks James. I checked that I had an ‘ssh’ with no extension and I had. Still no luck I’m afraid. Cheers

1 Like

Hi Lester,

Sorry for leading you in circles here, I can see that you started on this guide and this is a deeper issue.

We’ll keep looking into this but I’m a little stumped :frowning:

-James

1 Like

Me too! thanks for spending time on this. If all else fails I’m going to get an hdmi cable when the Brissie lockdown is over!

1 Like

I notice in my Windows settings that “open ssh authentication agent is disabled”. Would that make any difference? Thanks

1 Like

Hi Lester,

That shouldn’t do much if you’re using PuTTY, it should work out of box if your OS, ssh port, and network are functional.

Just to confirm, you’re using the IP address of your Pi in PuTTY, you can see the Pi in your router configuration, you’ve got the ssh file (no extension) in the boot partition, and you still see connection refused? Is there any chance you’re connecting to another appliance in your house that is (understandably) refusing the connection?

Once again, pretty stumped on this one, but if you could confirm you’ve done those things I’ll look deeper into this hole
-James

Thanks James, I don’t know how to check the router configuration. Is there an easy explanation? I have been using the IP addess of my router for PuTTY. Is this correct. I managed to find out how to do an ipconfig but there was no mention of the pi.

Hi Lester,

Ah, I think we’ve stumbled upon the solution. Your router has an IP address, but it doesn’t redirect that to your Pi or anything like that, it uses it for hosting a webpage to configure it. So you’ve got 2 ways to go here:

  • Download Zenmap and run a Quick Scan with your router’s IP followed by /24
  • Log into your router by entering the router’s IP into a web browser and entering the credentials (usually written on the back of the router) and look for anything that lists the connected devices

If it doesn’t show up there, you likely haven’t configured WiFi correctly on the Pi, or maybe something is faulty.

Keen to see how this goes for you
-James

1 Like

Managed to do both things. The router info was easier for me to understand. There were a number of things that were “Device name unknown” (haven’t yet figured out what they are yet) but nothing bearing any raspberry type name. Should it be identifiable that way or any particular way?

If I haven’t configured the wifi correctly, is there a way to fix that? Cheers

2 Likes

Hey David,

A quick check is to just run ping example.com from your command line to ensure that you’re connected to a network, depending on your operating system on the Pi you can either use a GUI or edit a config file to connect to a network, I’ve added a pair of tutorial for you below depending on what you’re running and most comfortable using:

Making sure that you’re on the correct network, that the appropriate network ports on your Pi are open and appropriate services enabled/running is a good place to start when attempting to rig up a headless board.

1 Like

Hi Lester,

I think Bryce may have missed the bit where you mentioned you don’t have display output, if you need a cable, maybe you could lump it into your next order from us?

Could you send through a copy of your wpa_supplicant.conf (With your password erased!!) so we can have a look for completeness? That’s a key step in making sure your Pi hooks into your WiFi successfully.
-James

wpa_supplicant.pdf (201.3 KB)
Hi James, attached is my wpa_supplicant file. Cheers

Hey Lester,

That appears to be valid (without personal details of course). If possible, I would highly suggest attempting to boot your pi with a display rather than attempting a headless and ensure that the setup is working and that it is connected to your network successfully (you can also double-check your IP address on the network) and from there ensure that there aren’t any issues with the port 22 not being open or locale not being set.

Hi guys. Discovered that port 22 is not open. Will folow up tomorrow. Cheers

2 Likes

Hi Lester,

Excellent, by the way, here’s another forum post regarding setting that up:

2 Likes