Having issues running a simple script in autostart

Having issues trying to launch a simple command or script via autostart on a Raspberry Pi. The problem is once the command is saved/entered and the Pi is restarted it comes up with a login window, instead of the pi interface(LXDE). Any help would be greatly appreciated.

RE: Mirko.

Hey Mirko,
Could you include your script and any links to the method you are using. I will try to recreate it here and get it working on our Pi setup

As mentioned, if you can simply add the @leafpad in the autostart folder first working, we should then be able to run the script successfully! What do you think??

the location of my Pi user autostart file is as follows;


Sorry - here is one of the links in question.


Ah, I think i am up to speed with this. Have you tried the method outlined here: http://curioustechnologist.com/post/90061671996/rpilooper-v2-seamless-video-looper-step-by-step

Let me check now! Thx,

Interesting, problem is the format I have is MP4 which I can convert. What I have noticed as you can see below, that you have to set the permission for the file created before restarting the Pi.

sudo chmod 755 seamless_video.sh

sudo update-rc.d seamless_video.sh defaults

Sorry Mirko, I’m not quite sure I follow why that’s a problem?

At this point. How can I make the Pi not come up with the login message after reboot.

Step 1: Open a terminal session and run raspi-config
sudo raspi-config
Step 2: Select Enable Boot to Desktop/Scratch from the menu and press Enter
Step 3: Select Desktop Login as user pi at the Graphical Desktop.
Step 4: Select and Enter, then select to reboot.

If this doesn’t work for you, you can try:

sudo nano /etc/rc.local

Add the line
su -l pi -c startx
before the exit 0 line

Try this out and let me know how you get on.

Sorry, I guess what I am saying is that his method in the link requires certain type of video format which can be played. My file is a MP4, which will need to be converted. The other question is the Pi at the moment, after a restart will come up to a login screen whereby you cannot login unless you go via terminal. Is there a way to auto login. Thx.

Yeah there sure is, see the above post.

Ah. ok. cool. I’ll give this a o as soon as the updates are complete.

Just curios - why did this happen in the first place if all I’m trying to do is to add a command in the autostart file.

It’s my understanding that the default bootup sequence in Raspian uses on startup is to prompt for a login/password. As you hadn’t changed that setting in your Raspi-Config setup, it’s likely that it’s completely unrelated to the file you are changing.

Oh. thx. You are the man. Thx thus far for your help! I’ll get back soon and let you know of out- come.

1 Like

No worries Mirko, we’re here to help!

Guess what, after major download issues, I have managed to download the image onto the SD and no luck – as this version is only works with Raspberry Pi model-2 and below, not model-3 as I have. Not sure if you can still help. Cheers.

RE: Mirko.

Hi Mirko,

What download image are you referring to?

Within the step guide, there is an already configured RPiLooper V3 image file which you can download and use. But apparently it is not compatible with the Pi-3 model - other people were also having troubles. What I ended up doing which worked a treat was from the below link.