Pololu Jrk G2 24v13 Motor Controller Not Turning On

Hi there,

I purchased a Jrk G2 24v13 Motor Controller to drive a 24V/8A DC motor via a Seeduino, using I2C between the Seeduino and Jrk Controller. My setup is shown in the images below, including the benchtop DC power supply use to deliver the required 24V to the Jrk Controller:

Initial testing found that when the Jrk Controller was set to deliver 100% Duty Cycle, the maximum current being drawn from the controller by the motor was only 1A and so it would barely run, given the motor requires 8A for max. output. If connected directly to the 24V DC power supply, the motor operated correctly and drew the needed current. Plugging the Jrk Controller directly into the computer via its USB-micro port, the Pololu Jrk G2 Configuration Utility Tool (Official GUI software for directly operating the controller instead of via the Seeduino) recognised the device and was able to control it, but still only achieving 1A at 100% Duty cycle. So upon leaving the lab, the controller was working but not outputting the current it should be.

I had planned to return the next day in order to troubleshoot this issue when I found that the Jrk Controller, being in the exact same setup as the previous day, no longer turned on. That is, the output terminals (OUT A & OUT B) of the board no longer output anything (0V only) no matter what target speed I told the controller to drive the motor at, none of the onboard LEDs turned on to indicate the controller was operational, and plugging the controller into the computer again, the Configuration Utility Tool couldn’t see the Jrk Controller at all, as the image below shows:

I’m wondering if anybody has any idea what’s wrong or any troubleshooting advice. Just stopped working overnight so it’s a little bit of a doozy.

Cheers and thanks for any help,

Hi Laurence,

From what you have described I can’t pick out anything that would indicate why the motor controller would suddenly die. It’s probably worth checking the basic things like checking your soldered headers haven’t caused a short somehow (they look ok from the topside).
Testing just the motor controller itself once it’s removed from the circuit with the computer GUI configuration may help isolate the issue further. Basic things like trying another USB cable or a different computer shouldn’t change the result but may help expose an intermittent fault in a basic component like your USB lead.

One quick question about your circuit, what was the orange jumper lead for?

Hi Spookee,

Thanks for the advice, I really appreciate it. Did a bunch of continuity checking using a multimeter and all the soldered connections seem good, no shorts found.

Tested out the motor controller isolated from the circuit, and the GUI Configuration Utility on the computer still can’t see the controller. Also tried another USB cable and another computer and both yielded no success :’(

As for the orange jumper lead, it is not connected to nor does it touch anything. It its an extraneous wire meant to extend that line of the breadboard over the middle gap if I ever needed it.

Unfortunately still not working but thanks for the help so far.

1 Like

Hi Laurence.
I know it sounds a bit silly but have you actually measured what voltage is arriving at the Jrk board. I can’t quite make out whether the meters on the PSU are reading the voltage and current settings or actual voltage and current. What is the LED that is on at the bottom left of the display. Can’t read what it signifies.
There is a possible scenario:
The meters are reading the settings not the actual voltage
The LED is indicating current limit is operating.
If the input to the board (and thus the output of the PSU) is short circuit somehow the PSU will go into current limit and the output voltage will be zero. If this is the case the board output will also be zero.
If the on board electronics is powered by the 24V via a 5V (or 3.3V) regulator the board comms to the computer may not function either.
The Amp meter is displaying 9.5A. What is this?? The PSU is rated at 180W so at 24V this equates to 7.5A. So if this 9.5A is actual current and the current limit seems to be turned up fairly high this could well be the PSU current limit limiting the current to 9.5A into a short circuit.
Just a thought.
Cheers Bob

1 Like

Hi Laurance
Found the operator manual for that PSU.
It seems that when the output is OFF (as is the case in that pic) the display shows the voltage and current presets and when the output is ON the Amp meter displays the actual current and if in current limit mode the “CC” (Constant Current) LED indicator is lit. If all normal the “CV” indicator will be lit and “CC” should not.
The LED at the lower left is the current operating mode.
That answers a couple of my questions.
Cheers Bob

1 Like

HI Bob,

Thanks a ton for taking a crack at the problem. With the PSU on I did measure the voltage arriving directly at the VIN and GND terminals of the Jrk Board and read 24V.

When the PSU is on, the voltage display shows 24V but the current shows 0A being drawn by the board.
If I bypass the Jrk board and power the motor directly from the PSU the supply is more than capable of delivering the required current.

I hope that answers most of what you were wondering.
The search for a solution continues.


1 Like

Hi Laurence
Well that gets rid of that possibility. I was only clutching at straws as I assumed that just owning a PSU of that quality and flexibility would indicate you know how to use it.

A circuit of the board would be nice but I wouldn’t hold my breath on that one.

Can you measure what is at “5V out” and Gnd a bit further down from the logic connections. That may be a clue. The fact that you can no longer communicate would indicate the failure of some low voltage logic supply as the device seems completely dead. There are a couple of 3 terminal devices on board, the big one top left is probably the output switching Mosfet. The small one could well be a 3 terminal 5V regulator. If you can identify this you may be able to measure the in and out voltage and get some ideas.

I am at a bit of a loss as to what else I can suggest remotely. Sorry about that.
Cheers Bob
EDIT: I meant “the big one on top right”.


Hey Bob,

Measuring at 5V out and GND further down from the logic connections while providing power (i.e. 24V to VIN & GND) to the board still reads 5V.

Measuring the terminals of the two 3-terminal devices, the large one on the top right appears to be stepping the 24V i/p down to 5V and doing so successfully, with 5V measured on the output terminal.
The smaller one appears to be a Mosfet, with the Gate at 5V, the Source at 0.135V, and the Drain at 0.6V, if that information helps at all. This really is a doozy.

Thanks for doing your best to help out, I know remote troubleshooting is really tough.


1 Like

Hi Laurence
Like you say, a “doozy”. It would appear that 5V is appearing at a couple of places anyway.

Along about now a circuit would be extremely useful. Are you sure that small one is a mosfet. If so and N channel it is hard on. If a P channel it should be off. I am not sure what it could be. The voltage of 0.6V is really suspicious as this is the normal base / emitter voltage of a switched on transistor and I would expect the voltage drop across a mosfet to be less than that.

Is anything getting hot?? bear in mind that just because something is hot to the touch does not mean overheating.

About the only thing I can suggest without a circuit is to disconnect everything and very carefully start again as if the board has never been turned on before. Document everything. I also find it suspicious you only ever got 1Amp from the thing at any time and would not provide the current to drive the motor. Something was basically wrong here and may have a bearing on ultimate failure.

You have probably seen this but I found a user guide here.
Pololu - Jrk G2 Motor Controller User’s Guide.
Which seems to have lots of links to different procedures.
Sorry I can not be of more help but I know nothing of this particular device.
Cheers Bob


Hi Bob,
Really appreciate all your efforts.

Nothing is getting hot from what I can tell. Have indeed started from the very beginning with the board, with everything disconnected, and still found no success :’(

I was wondering if I had any recourse for a replacement or refund here. Please let me know


1 Like

Hi Laurence

I am afraid you are asking the wrong person here. I have no commercial affiliation with CoreElectronics apart from being a customer.

Did you purchase this from Core?? If not you can’t expect any joy there and you will have to contact whoever you purchased from.
Best of luck.
Cheers Bob

1 Like

Apologies, I thought you worked at Core hahaha.

I did purchase it from Core so I’ll give them a call tomorrow.
Thanks again for all your help. You’re a top bloke


1 Like