Raspberry Pi to Particle Cloud

I am having issues getting the Particle agent to run on the raspberry pi

When installing the particle script, I keep getting:
⠸ Claiming the device to your Particle account
Error claiming the device. Could not claim the device to your account

the install script then exits

Hi Peter,

What type of RPi are you using? Can you check your server key file and make sure its not empty?

Let me know what you find!

The file does not seem to be empty. This is what is in the file:

$ hexdump server_key.der

0000000 8230 2201 0d30 0906 862a 8648 0df7 0101

0000010 0501 0300 0182 000f 8230 0a01 8202 0101

0000020 be00 becc db43 ea8e 2715 bba6 6d52 51e1

0000030 a02b ccab 64a1 4877 7cad fc66 7f80 99f6

0000040 25a5 f2f2 e0da cf43 263a 9ba4 87a1 0e03

0000050 8d9a 9a23 eabc ea99 d368 145a 26b1 bd0f

0000060 6daa 0c6f c4ac 2c77 c5d1 b1c8 7bd1 e068

0000070 7325 527b 6889 bd20 c606 e6f0 3000 e0c0

0000080 f6cf 3a1b e945 5bc4 1755 a306 4ad3 d5c6

0000090 d2b8 0217 27b5 8d7d d4e4 d37d c0ed 8a1d

00000a0 257c 211e 514a 57ae dd06 bc60 34a1 aa90

00000b0 09cc 3b9e 413a 3c4c f39d fdfd 27b7 59c1

00000c0 9881 6054 624a a47a bf9a 92df 3e1b a7fc

00000d0 a4e4 3ab3 5f9a 9357 eb8e 6419 2295 2c4a

00000e0 60d5 f9f5 03d0 8350 c069 536b f0f0 f8da

00000f0 8213 cc1f 5fbb c1e2 3adf 7fe9 e25d b97d

0000100 8050 583c ef33 f38c 3f80 0111 68d2 5f86

0000110 5e3c c1e6 328e 282b b5cb 1bcc 50a8 a75e

0000120 020d 0103 0100 ffff ffff ffff ffff ffff

0000130 ffff ffff ffff ffff ffff ffff ffff ffff

(Attachment server_key.txt is missing)

System is Raspberry Pi 3B running:

PRETTY_NAME=“Raspbian GNU/Linux 8 (jessie)”

NAME=“Raspbian GNU/Linux”


VERSION=“8 (jessie)”

Mail](https://go.microsoft.com/fwlink/?LinkId=550986) for Windows 10

Hi Peter,

Are you running a fresh account with a new device name?

There is some pretty good troubleshooting of this problem in this thread:

They link to another good one in the first entry. The thing you should try first is updating to the latest version of Jessie

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

I am just using the same account as I have for the photon. Have you been able to connect an rpi to the Particle Cloud without any issues?

Thanks I will check this out!

I did try all these procedures but still get the same issue. particle-agent will not load.

Would be interested to hear if anyone has managed to install particle on a raspberry pi successfully


I haven’t tried it myself, but the people who wrote those forums confirmed that they got it working so it must be possible. Keep at it!

the raspberry pi particle project has been discontinued: https://docs.particle.io/guide/getting-started/start/raspberry-pi/#particle-pi-discontinued

I suspect it does not work with the latest versions of raspbian etc but very interested to see whether anyone has got this working

1 Like

Interesting. I think that it would still work. There are no changes in the RPi 3B+ that should prevent it.

could you possibly try this to see if it works? The install instructions are at:

I solved all these issues. It was simply an installation issue withe the apt-get and sources.list file.


Hey Peter,

So others with this issue might benefit from it, could you share how you fixed the issue with the apt-get and sources.list file?


Yes will do when back from holiday


1 Like

Resolution shared here: