USB to TTL Serial UART RS232 Adaptor (PL2303) (018-USB-PL2303TA)

This is an interface chip. One side is talking TTL levels on the USB side for talking to a host/PC, the other side is the RS232 side for talking to the line side equipment.

Also handles CTS/DTR etc appropriately.

Yes, you’re exactly right. It’s worth noting that RS232 doesn’t always infer ±5V (which this chip does have the capability to do as listed in it’s description) the valid voltage is actually in the range listed in the quote below, RS232 also dictates a bunch of other standards regarding data transmission, similarly to Transistor to Transistor Logic (TTL). Though there’s several similarities between them, they’re not identical. This device just happens to have capabilities with both standards. I hope this helps!

Thanks for the information.

I’m no expert in this field. If this device has compatibility with both standards, does that mean it can be sent a signal complying with RS232 and somehow interpret it correctly?

Hey Luke,

As long as it’s within the appropriate voltage range, and your machine has the correct drivers for it, yes, you should be able to. Although, I’ve never had to use this particular adaptor myself with RS232. It might be worth checking out some tutorials on the use of RS232 in electronics projects before diving in assuming direct compatibility with the standard.

Thanks for the reply, Bryce.

I already have one of these but it isn’t correctly interrupting the RS232 signal it’s sent. The output is gibberish. I have a different RS232 adapter (that doesn’t include TTL in the spec) and it can receive and decode the signal correctly. That’s why I was asking about compatibility between TTL and RS232 on this device. My reading suggests they quite different signals so I’m unclear how it can switch to decoding one or the other.

I’m not sure if there is actually anything I can do to make it decode the RS232 signal it references support for. At this point, I assume it doesn’t support true RS232 signals.

After writing that last comment I was browsing the shop for an alternative and found the following description on a different adapter:

“Note that this provides (approximately) ±10V serial (RS232) not 5V serial (TTL), good for old devices like GPS, handhelds, programmers, etc with chunky DB9’s on the side. Some cheaper RS232 cables ‘cheat’ and only give you 0-5V which wont work with some devices - this one has a true voltage doubler/inverter to make it more compatible.”

This seems to explain what I experienced.

Thanks for letting us know Luke,

That’s excellent, if you’d like to reply to your order confirmation email and let the team know that Bryce asked, I’ll get a store credit organized for your original converter which wasn’t suitable. It’d likely be suitable with some projects with that hack they’ve made on the voltage, I’ll see about getting a notification on the product page to make this more obvious. Glad to hear that it’s sorted out and you’ve now got the appropriate adaptor, have a Merry Christmas!

Core Electronics | Support

I was wondering if this item could be used in this manner:

  • USB end connects to a laptop,
  • the four pins at the TTL side to a Raspberry Pi
  • then control the Raspberry Pi using the laptop

Hi Reymond,

Welcome to the forum! :partying_face:

What an interesting application. I know that it’s certainly possible to connect to a Raspberry Pi via serial, and it should be possible with this particular adaptor, but I don’t have one of these here in the warehouse to quickly double-check compatibility for you. I’d start by reading the tutorial below, it should cover all the basics for how to set that up. Have a great day! :grin:

1 Like

Thanks for the welcome.

That guide describes the one and only reason I need a USB to TTL serial cable.

How does this item differ from ?

: for the blue one you describe and linked above…i use it on my pi and it is quite fine to use on headless applications …for windows …or linux just use minicom as the console for it or putty if you wish …either work with the blue unit… the difference is the one in this thread is 5v or 3.3 volt adjustable logic state level …but u must dismantle the case and swap the voltage pin over…
have a read…@ Reymund15


does this work with the raspberry pi?

1 Like

Definitely will. Virtual COM drivers are part of the Linux kernel, so they’re plug and play.

1 Like

Just wondering if anyone else has found the following problem: I bought some SKU: 018-USB-PL2303HX and the ones which were supplied are blue. When connected between a raspi 4 (Bullseye & latest upgrade) and a custom made Sensor Board there’s no problems - program is written in Python & running 38400,8,N,1. I quit the program and run Putty to change settings on the Sensor Board. It ignores all keypresses even when TxD is connected to RxD. When clicking the x at top right of the window to close Putty it pops up a confirm box but then ignores clicking Yes to quit and ignores the x at top right of both boxes to close the windows. Eventually after a bit of clicking a pop up box finally appears saying Putty not responding and if I want to end the process.

So I plugged the USB to TTL adapter into my laptop (win10 enterprise) and connected TxD to RxD. Running Teraterm - no problems, all keypresses are echoed. Running Putty - same problem as raspi4, it freezes & there’s no response except that I can close Putty by clicking the x at top right of window. I downloaded a utility from Prolific to check the adapter’s chipset - it’s a PL2303HXD.

Has anyone seen a similar problem with this adapter and Putty? BTW I haven’t tried minicom on the raspi4 yet to see if the same problem occurs.

An update:
With RxD connected to TxD I tried minicom on the raspi4 and it also didn’t respond to typed characters. I then changed the flow control setting to ‘None’ and it started echoing what I typed.

So I went back to Putty and also changed its flow control setting to ‘None’. Hey, it works now.

Hopefully the above info might help anyone who comes across a similar problem with those adapters & Putty in the future.

all the best


Awesome thanks, that fixed it for me too.
WIN10 Device manager had flow control as “none”, but Kitty (putty upgrade) had it as “xon xoff”
Changing it to “none” in kitty got it working.

edit: nope, that worked to get a response from a loop back test, but when connected to a device, i only get a signal, but still cant send one. Other device i have works in serial just fine ch341a :frowning:

edit edit: The driver that auto installs with WIN10 doesnt seem to work, it looks to install ok but nope.
I ended up using the older driver from win 7, so far seems to work.
Can get it from core-electronics link

1 Like