ADAFRUIT FEATHER NRF52840 EXPRESS - cannot see it on mac

hi Team,
I acquired a couple of the Adafruit feathers from you guys. ADA4062
I am trying to connect to them so I can flash them using the Arduino IDE on a macbook.
I am following these instructions:-

however I am unable to see the device itself in the list of USB devices. I understand it should be visible as soon as I plug it in. It’s not, and as a result - i cannot move forward.
I have tried both of the Adafruits I purchase (2 x ADA4062) and I have checked the cable works (other devices appear as soon as I plug them in)
I have even tried 2 x macbooks.

I am likely doing something stupid, but I cannot work it out.

Please advise any suggestions or solutions!


Hi Pete,

I’m very sorry we missed this one!

Just to make sure we are covering all of the bases have you installed the CP2104 driver? (Link to Adafruit section on their site)

I’ll do some more digging to see if its even being detected in Mac OS - something like device manager.

EDIT: running the command ioreg -p IOUSB -l -w0 should show the connected devices if any are present, also Apple menu > About the Mac > System report > Hardware > USB. This should display the list of connected devices, if another device/Arduino handy a good check would be plugging one in.

If that doesnt work, this forum post walk through a few steps to get going: Arduino IDE is not showing any port macOS - Stack Overflow
Some key points are:

  • Make sure you arent pulling too much current through the USB port, i.e. shorts on connectors, if its resting on anything metal or stuff has been soldered onto it
  • Make sure the drivers are up to date
  • Unplugging everything except the microcontroller (MC) - including USB hubs



Hi pr
Probably not much to do with your problem but may be relevant.
Some time ago purchased a NanoEvery and it could not be seen or located per the Arduino IDE. I somewhere found out that the web based version of the IDE found devices automatically if connected when Arduino IDE started. This worked and since then I have had no trouble. The NanoEvery appears whenever I use the “normal” IDE when I require it.
May be worth a try. Connect your device then start the web based IDE and see if your device is found.
Cheers Bob


Thanks for your help team !
As it happens - I solved it.
It turns out the adafruit doesn’t power up and appear in the device list until you double click the reset button on the feather! This isn’t explained at all in the Arduino Article for the NRF2840, but it is available at the following URI…if you know to look for it.