Adafruit FONA GPS not working

Hi all!

I’ve recently got my hands on the 3G Adafruit FONA module and have been using it with the Arduino UNO (as well as MSP430).

The GSM component has been working great and I have been able to send a text message from the module however the GPS component seems to be not working. I am using the recommended active antenna.

I have tried this on both the Arduino as well as MSP430. I have also tried connecting the module directly into the PC to stream NMEA data and this is the output:

I have tried taking the module outside and I still could not get a fix after more than 30 minutes:

Any suggestions please?

Hi Anwar,

Good to hear that you’re up and running with the GSM side of things. I haven’t had a huge amount of hands-on time with the GPS modules, however, @Aidan has done some work with them and will be back in tomorrow morning.

The GGA sentence (essential fix data which provide 3D location and accuracy data) suggests the GPS doesn’t have a lock yet. A cold start can take a couple of minutes to get a lock - have you given it a solid few minutes to do so?

Also, perhaps prop the Antenna up a little (off the ground). It might help with reception.

Thanks for your replies.

Yes Graham I have left everything running for over 40 minutes at one point with no luck. I have elevating the antenna about a metre off the ground too

I have recently read that I needed to solder the bias copper pins (https://learn.adafruit. com/adafruit-fona-3g-cellular-gps-breakout/pinouts under Antenna Ports) and have had this done this but still can’t seem to get a fix at all:

What else should I do please?

1 Like

Thanks for giving those tips a go Anwar. I was hoping it was going to be something simple, although given that didn’t work, the best way forward is to get in touch with Adafruit technical support

Please do let me know how you get on, and what the fix is.

Thanks Graham,

I have emailed that address and will let you know if I get a fix!


Hey guys, so…

Good news: Adafruit was very hepful and immediately offered to send a replacement module

Bad news: GPS does not work on the new one either :’(

As before, I’ve soldered the bias pins (tried before soldering and did not work either) and have tried the following:

  1. Plugging module straight into PC to read NMEA stream from GPS. Result is very similar to the first module (attached above). Also tried manually typing AT commands for GPS and result is: +CGPSINFO: ,

ampI/ampQ = some_number/some_number

  1. FonaTest and GPS example libraries on the Arduino Uno, the result of which is commas for the NMEA string and no fix found

  2. Tried similar code on MSP430 using Energia

p.s. I am using a different active antenna and SMa to uFL wire so I don’t think that’s the problem.

Has anyone managed to get the GPS to work on the 3G Fona module? If so, how did you go about achieving this?

Any help would be much appreciated. Thanks in advance!

Hi Anwar,

Did you note this tip from Adafruit on the user guide:

On the left is a GPS antenna port. While you can connect a passive GPS antenna directly, we’ve found the performance is lacking. We recommend shorting the solder jumper labeled ‘bias’ and connecting an Active GPS antenna instead, such as the one we stock in the adafruit shop

Edit - I see you have. Hmm. It would be best to engage Adafruit as they are certainly better prepped to manage edge cases such as this along with the fault finding they are going to want to carry out on your end given they’ve already replaced the unit.

1 Like

Here is my solution to SIM5320E modules that would not acquire a fix at all.



This sounds trivial, but did you try at+cgps=1 to cold start new gps session upon boot?

1 Like


Could you please tell me, How did you manage to get a GPS fix? I’m working on the same project as you were. any inputs will be helpful for me. Thanks.


It’s been a while since I’ve worked on this project but I eventually did get the GPS working. Pretty sure the first module’s GPS was not working as the 2nd one got a fix after leaving it outside searching for a while. After the first fix, subsequent fixes were retrieved much quicker.

Good luck!

1 Like