Adafruit Ultimate GPS stopped working

Hello team,

I’ve got an Adafruit GPS module and it stopped working on Monday (the “Fix Led” doesn’t come on when power is connected). The GPS unit was working fine, in my Car connected direct to the Raspberry Pi 3 v3 pin. I noticed the unit had stopped working when I removed the Pi and GPS unit from my car and took it inside to be powered up via USB connected to my Laptop. The Fix light flashed as normal and then went dead. I thought it may have been the cables, which I’ve switched and the result if still the same. Typcially when I bring the unit inside, the LED flashes continually while it tries to get a fix.

Are you able to suggest anyway of telling if the GPS unit is still alive?

Thanks, Andrew.

Hi Andrew,

Are any lights illuminated on the board? What happens when you power it up outdoors in its original condition? It sounds like the problem was caused by removing it from the setup in your car. Can you include a photo of how it is wired up to the computer in the house?

G’day Stephen, here’s the photo (its a bit messy as the GPS is part of a prototype).

There’s no lights on the GPS board working at all, the pi power and act lights are flashing periodically; I also have an LED that flashes when a bluetooth device is connected and that’s still working.

Hi Andrew,

It looks like the problem is the power supply to your Pi. The power light on the Pi should be solid red all the time. Flashing indicates a bad power supply, or too little power. The Pi needs at least 1.2A to run properly, not counting external devices it’s powering. A typical USB port will provide 500mah only. Try powering it with a 2A or greater 5V power supply and see how it works!

This could explain why it worked in the car and not on the bench.

It’s also not likely to get a fix from indoors. You could monitor the NMEA sentences directly to see how many satellites are connected, though from my experience this module works best outdoors.

A GPS fix can take several minutes sometimes as well.

Hi Stephen,

I’ve switched out the power supply and now there is a constant red light, but the GPS module isn’t firing up. I also tried connecting the GPS to a direct 5v power supply but there was still no “fix light” flashing.

Do you know if there is anyway, other than seeing the fix light flash of confirming the GPS is working?

I’ve had it running previously on /dev/serial0 and I could see the output using “sudo cat /dev/serial0” but there’s nothing coming through atm.

Thanks Graham; previously while it was getting the Fix, the Fix light flashed every 0.5 seconds or there abouts, but currently there is no sign of life in the unit.

It would be best to view the NMEA data on the GPS module TX pin, if you are still indoors then it’s not going to flash as that indicates a lock.

Viewing the NMEA sentences will reveal what the device is doing, you could use an Arduino to do this. Here are some tips

Howdy, I took the GPS unit outside with the adjusted power supply and waited for ~5 minutes, no sign of any activity on the Fix light.

I was about to order a second unit in any case; am I able to send this one back to you for testing in your lab?

Hi Andrew,

We don’t have a service like that sorry - though you do have a Raspberry Pi on your hands, so you could view the raw NMEA sentences with it. Here’s a guide:

And here’s a guide for each of the NMEA sentences:

The GPGGA sentence will have the most useful info in this case.

Hi Graham, I’ve tried the instructions above and there isn’t any output from the GPS on the serial port :frowning:

Have you tested something that ‘does’ work with a valid UART signal to ensure the script is working?

If you don’t have anything else, then you could use a digital multimeter (configured for voltage measurement). Connect it between the GPS TX and Ground - if it reads anything other than a very constant 3.3V then it is likely data is being sent. If your DMM has frequency measurement, you could also monitor it that way.