Argon one V2 video problems

I got the argon one v2 case and most of the times it works great.
However, I’m getting a weird problem with the video output.

When I’m plugged to a monitor directly through an HDMI cable it’s ok. But when I try using the same monitor but through an HDMI to VGA converter and a VGA cable it doesn’t show anything.
It also doesn’t work when I’m using a projector, either with HDMI cable or a VGA cable with the adapter.

Everything used to work before getting the case (including the adapter), so I’m thinking that there is a problem with the extra board that comes with the case.
I’ve tried some solutions that I found on this forum by adding/changing lines on the config.txt but nothing seems to work. To be honest I’m not completely sure what those lines actually do, now I have them all commented out with an “#”. I didn’t use them all at once, I just left the ones that I’ve tried so I wouldn’t repeat them. Here is the list:


One more thing to add. If I’m plugged to the monitor directly though HDMI and I plug a second monitor through a VGA cable (with an adapter) both screens work.
It seems that it can’t boot correctly if I’m not plugged directly through HDMI.

I have a raspberry pi 4 2GB ram and I’m using manjaro xfce.

I really need it to work with the projector and the VGA cable.

Any suggestions will be appreciated.



Welcome to the forum :slightly_smiling_face:

I won’t pretend to have memorised the meaning of all the different configuration options for HDMI, but I think I have a suggestion to see what the Pi thinks the adapter is.
The HDMI on your Pi can run in two different modes, by running the tvservice command to query your display with the adapter connected you might be able to see what mode the Pi thinks it should be running in.

Also, have you made sure to have the full setup connected when the Raspberry Pi boots? Hotplugging devices can be a bit hit or miss on the Pi so you may find that a setup would work if it was connected as the Pi booted, but wouldn’t work if connected after the Pi is already running.

Thanks for the answer.
I’ll try to see if I can find a solution there.
Regarding you last comment, the configurations I’ve tried were all set up before turning on the Pi.

1 Like