DFRobot A9G GSM/GPRS/GPS Module mobile network issue

I have just bought an A9G GSM/GPRS+GPS MODULE, TEL0134 and paired it with USB TO TTL CONVERTER (CP210), TEL0010 as well as an OPTUS prepaid SIM card.

I am having problems getting it to register on the GSM network. Specifically it gives the following codes when tickled:
It is happy with the SIM installed and it isn’t locked (AT+cpin? => +CPIN:READY)
But it won’t register on a network (AT+CREG? => +CREG: 1,2).
I have check the signal (AT+CSQ => +CSQ: 0,0) which I believe is ok?

When left alone for any length of time it just keeps spitting back: +CREG: 2 every minute or so.

I have tried the OPTUS SIM in an old phone, there is no lock on the SIM and it sends and receives calls and messages.

Any clue as to what I have done wrong to prevent it working? Suggestions for things to try?

1 Like

A couple of things to check;

Power required when registering - GSM modules have a spike in power consumption when registering with a network so ensure that you are getting consistent voltage on power in rails during registration

Antenna - what antenna are you using?

1 Like

I should also mention that CSQ: 0,0 is not usually a good sign. When using these modules or others when i get that it usually indicates an issue with signal/reception/powersupply/antenna


Hi Arnold16700,

Thanks very much for your prompt replies.
I wasn’t sure about the CSQ: 0,0. Good to know that is a place to start looking.

I am using the antenna which came with the unit. It doesn’t look huge, but I have no idea what sort of gain it has. Or if the unit can be matched to a larger antenna.

I haven’t done anything special with the power supply, it is currently being fed off 5V from the USB TTL / UART converter connected to my laptop (through some small jumper leads).
I have seen some other posts on the web about power delivery to these units.
My next step will be a small switchmode supply from Jaycar by the looks… Will try that this arvo and see if I can’t get the unit to respond.

Cheers for your help!

1 Like

Also try the CSQ command without the SIM inserted and let us know what the AT response is then

1 Like

Hi Arnold16700,

Before a proper power supply boost, I thought to perform a test with no SIM installed.

It still fires off the +CREG: 2 every 1min & 3.7s.
AT+CSQ => +CSQ: 0,0
AT+cpin? => +CPIN:NO SIM
AT+CREG? => +CREG: 1,2

As a quick test I plugged in a 20,000mAh power bank (ORICO) into the USB micro port (in conjunction with the 5V from the USB to TTL converter) to see if that would bolster it. But there was no change with or without the SIM.

Looking at the circuit I realised that I need a 4.2V battery (Li-ion) for the multitude of Vbatt connections.
I was about to solder in an old Li-ion battery out of a Samsung Mobile phone. It is 3.8V, 9.88Whr capacity.
The thought struck me that it might not be a good idea.
The schematic for the A9G shows a DC-DC converter on the board (SY8089) but it doesn’t look like this does any of the good things for the battery charging like CC/CV function, or have over discharge or short circuit protection.
Am I reading this right? It would seem another circuit is required for battery charging and safe keeping which has a ‘battery’ output to connect to the A9G circuit.

Will solder it temporarily and see if it will communicate.

1 Like

So …

the result with bench power supply (5.2V and current limit =5A) and with or without the battery (Samsung Li-ion, fully charged, 4.3V) is the same as before. Battery is soldered onto the board where there were no headers populated. Wires soldered onto the top of the gold connections of the battery.

It can still see the SIM:
AT+cpin? => +CPIN:READY
The signal strength is rubbish / doesn’t exist
AT+CSQ => +CSQ: 0,0
I discovered a function for the CSQ which shows what to expect from the result.
AT+CSQ=? => +CSQ: (0-31,99),(0-7,99)
There is a write up on it here:
AT+CSQ – Signal quality | M2MSupport.net

The network status still shows it looking but not finding. I guess no suprise since there is no signal strength
AT+CREG? => +CREG: 1,2

I did notice that at about 10mins after powering it up it volunteered the message:
+CIEV: “Complete the Charge”,100%

I tried:
AT+CREG? => +CREG: 2,2,“0000”,“0000”

When I reset I get this:
at+rst=1 => OK
+CIEV: “Charging”,97%
^STN: 3
A bit less than a minute later I get a:
+CREG: 2

I thought perhaps where I was doing this had poor mobile reception so I moved until I had 3/4 bars on my phone. I found a page on my Samsung phone which shows the signal strength as varying between -94 dBm and -98dBm 42 asu (this is with 3/4 bars). Still made no difference.
I wondered if I had mashed the connector for the antenna when putting it on. It is a tough little thing for something so small, but it looks ok under 10x magnification after pulling it off. put it back on and moved it around. No difference.

When I powered it up with the bench supply and no battery (5V from USB UART disconnected, except 0V ref) it was drawing about 50-70mA. When I turn on the GPS it jumps up to 100-110mA or so.
When I connected the battery and bench supply, the bench supply draw was 0 or close to it. As the evening / morning is dragging on the current draw is increasing to 30-40mA. I suspect with the battery coming off its full charge high of 4.3V.

I haven’t seen anything like the suggested 3A of draw, unless it is too quick for my supply display refresh rate or it is not talking to the GSM network properly.

The only thing it seems to do successfully is waste my time… ;-(.

Any other ideas?

Has any one tried this module with a garden variety OPTUS prepaid SIM and got it to work?


1 Like

What a head scratcher! Hopefully some others on here may have some input.
CSQ results of 0,0 do indicate something is not right somewhere. I’ll keep thinking it over. If anything else comes to mind I’ll post it here.

1 Like

A silly question perhaps, but does this A9G module actually work on 3G or 4G? On an active mobile data network in Australia in 2020?

Apparently the 2G network was de-commissioned in Australia back in 2017. So if it only works on 2G then it was never going to connect to a network, and my efforts were always going to be fruitless.

Further to the above, I reference a ‘customer review’ from Leigh (verified purchaser) on the product page:
No active GSM networks still operational in Victoria, but that doesn’t stop this board being really cool. Would work really well as a GPS datalogger. (Posted on 23/11/2020)
Is Leigh correct?


Hi All,

Very sorry - this one has slipped passed our check gate! Our system auto imported this product from DFRobot’s listing. This is a 2G device and there’s no 2G networks in Australia anymore. The frequencies used for GSM have been reallocated for 4G standards.

The A9G will still of course work as a GPS as per Leigh’s review, but not as an IoT modem. The A9 is more or less useless in Australia.

We’ll send an email out to all affected customers ASAP!



Hi Oliver,

So how about a replacement device with modem (SMS and phone calls) which works on the 3G/4G network? Am happy to return the A9G which doesn’t do what I bought it for.

Regards, Graham.


Hi Graham,

Just an FYI though, GSM coverage is still available in NZ. Regretfully there’s really not a lot else available around the same price point. Pricing aside, here are a few options:

The MKR 1500 is definitely well supported - Telstra have partnered with Arduino for this one: https://dev.telstra.com/iot-marketplace/arduino-mkr-nb-1500

This one is a top of the range do it all board:


Hi Oliver,

Thanks for the links, a few are new to me.

Coming back to the original point though… You sold me an item which was never going to perform its stated function (at the time of the sale, you have a warning on the product page now). I wasted a bunch of time fruitlessly trying to get it to work and have also been delayed in completing my project.

Just wondering what you are going to do to make good on the situation?


Hi Graham,

Some people will have bought these fully aware of the limitations, as they’re still a really cheap little dev board and the A9G is a very cheap dev board with on board GPS, while others like yourself won’t have a need for them any more so it’ll be case by case depending on what customer’s individual needs are.

We’ll be sending out emails to everyone who’s bought one very shortly - just hang tight for a bit and we’ll get it sorted for you :slight_smile:

1 Like

Oliver, I see you have not listed your nb-iot module

as a possible alternative. Is there a reason for that, as it would seem to fit my requirement for doing simple REST calls to our server? I realize I would have to get a specialized SIM card, but the one from ThingsMobile would seem suitable, and claims to work in Australia on the Optus and Vodafone networks. https://www.thingsmobile.com/private/plans
1 Like

Hey Charles,

It’s quite a newly listed product and I just didn’t happen across it when looking for some alternatives.

It does look like a handy little module, but I do note it is based on the SIM7000E which I haven’t played with before but am aware there were a few difficulties with it in the past (do a quick search for sim7000E in the forum search) to read up on those threads.

It does support the 700MHz LTE Band 28 which is practically ubiquitous in Australia so it should be quite functional, it just may be a bit fiddily getting it working the way you want. However, it looks like Waveshare have done a better job of providing documentation and support for their implementation than DFRobot did, so that’s certainly a big plus.

1 Like