DFRobot SIM7000 with botletics library GPRS and GPS wont work

Hello everyone.
I have been trying to make a gps tracker using a DFRobot sim7000 to try and send longitude and latitude to an MQTT server using a 3g/4g connection but I can’t seem to get it working.

I couldn’t get it working with the DFRobot library so i was advised to use the botletics library. I read the guide on here and came up with this code for submitting longitude and latitude to a mqtt server using celluar.

This is the output of the serial monitor

and this is the code that causes the errors. I have also tried commenting out the EnableGPS code to see if GPRS would work but that doesn’t work either.

1 Like

Hi Daniel,

I had a look at the library code, and it looks like it does support the 7000 and 7070, but I’m not sure why other functions would work, but not GPS, all the functions just send and receive AT commands over serial.

Have you tried hooking into the RX and TX lines of your shield with a USB-to-serial converter to see if sending the commands manually gets a response you can decode?

It’s also good to not rule out hardware issues, could you attach a photo of how you’ve got everything hooked up?

Keen to get to the bottom of this one!

1 Like

Yes, the DFRobot SIM7000 has a USB port and I have succeeded in using it with AT Command Tester software where both cellular data works and GPS works. So the problem is with both the botletics library and the default DFRobot SIM7000 library

1 Like

If botletics libary isn’t going to work for me how would I go about debugging and finding out why the attacthService function in the DFRobot library doesn’t work since the GPS features in the DFRobot library work

Here is DFRobot SIM7000 library with the only change being made is changing the APN from cmnet to internet in attacthService void

1 Like