DFRobot SIM7000E Shield - Serial Port Issue

Hi All,
We recently purchased DFRobot SIM7000E Shield. Tried to Interface with AT Commands in DFRobot SIM7000E Shield . For that we used FT232L USB to TTL Converter

Our connection was as follows :

Tx of TTL Convertor - (D1) Tx of DFRobot shield

Rx of TTL Convertor - (D0) Rx of DFRobot Sheild

VCC of TTL Convertor - Vin of DFRobot Shield

GND of TTL Convertor - GND of DFRobot Shield

We tried on D0-D1 mode and D7-D8 Mode

in D0 D1 Mode

D0 - Rx

D1 - Tx

in D7-D8 mode

D7 - Rx

D8 - Tx

While opening the serial port in Serial terminal. we are not getting AT Commands response from the DFRobot sheid when we press BOOT Button at that time we are getting print statements as like +CPIN : READY +CFUN : 1 SMS READY But at the same time while typing AT we are not getting any response from the Board.
Whether this is our Connection Problem? Any valuable comments will much appreciated.


Hi Sheker,

This product is intended to be used as a shield connected to an Arduino. I can’t really speak to its behavior when interfaced with a FT232L USB to TTL Converter. Take a look at this thread and see if his solution might be related:

Hi Stephen,
Thanks for the response. We are not considering connecting Arduino board to DF RObot 7000E. We are trying to access DF directly by bypassing to power up the DF & send and recive the data externally by using FT232L USB to TTL Converter.

We are able to receive the data from DF 7000E if we hold the boot button for couple of seconds but when we send its not responding. We were wondering if any one have similar issue in connecting directly to Df board and which ports they used in resolving the issue?

One post very close to the issue, posted by Mel

" Initially, I could not get the sample code to work, or the library, so I bypassed the arduino side altogether, and connected a UART directly to pins 7&8 and ground and talked to it directly. The unit seemed to have issues with baud, and some googling showed that the UNO software serial code got around this by trying to send the first command that would set the units baud from 115200 (too fast for sw serial) to 19200.Also worthy of noting - the UNO did not seem to have enough power to allow the unit to boot while holding the BOOT button for the documented 2 secs. Plugging the unit into an externally powered DUE solved this for me, but perhaps I have a faulty UNO regulator."

Any thoughts or ideas are greatly appreciated.


Hi Sheker,

What do you have your baud set to on your devices?

Hi Stephen,
On Putty I used 19200.

Hi Sheker,

In putty try using 115200. As mentioned in your last post this shield defaults to 115200 and the Arduino changes it to 19200 when the first command is sent. Since you have nothing commanding it to 19200 its likely staying at 115200.

Let me know if that helps!

Thanks Stephen. Let me try that!