Sim 7600 arduino shield sku tel0124

have recently tried to use this board following steps outlined in the dfrobot product wiki.
i currently have it plugged into a uno wifi rev 2 arduino controller board.
when i type in the at command i get rubbish characters as you might expect form having incorrect baud rate settings. i am using 115200 as specified in the code on the wiki. i have set the baud rate on the arduino ide serial monitor to the same and i have set the com port baud rate to the same in device manager. i am using a fresh install of arduino ide on a windows 7 machine. i have the rx/tx jumpers set to 0/1 (rx-0 tx-1) as per this particular board. (no other jumpers in place). i have set the rx/tx to the same in the code.
as per the wiki it sayst to connect the shield to the arduino and then upload code. i am wondering if the firmare in the sim7600 shield might have been corrupted from this process, ie should the wiki say that code should by uploaded to the arduino before connecting to the shield?. if this is what has happened can i rectify it. if this isnt the problem are there any suggestions as to what it might be.
as a secondary thought- is the wfi part of the uno getting confused by the at commands or is this not relevant.
hope someone can help

Ok, insert red face here. Changed jumpers back to 7/8 (rx/tx) works fine. Board pins are labelled 0/1 but that is between boards, not software serial ports. Happy days.
Thanks tim and co for your help

1 Like

it’s me again
found that software serial was struggling at 115200 and so changed it to 9600 at the start of code. was running fine untill i put project on the shelf for about eight months. now i can get a rapidly flashing blue light (connected to network)but that is all.
it wont respond to AT commands at all.
i have reloaded script from the wiki and have done as the wiki says to to the letter but still no response. i have tried different baud rates on both the software serial and the hardware serial (and serial monitor) and confirmed them in device manager. settings on arduino ide are as they should be (using uno wifi rev2). jumpers are set to 7,8 as in the posts above
i have tried using jumper wires instead of mating the board and shield.
i have tried loading a different script to uno and that communicates with serial monitor.
i have tried turning it off, disconnecting everything, leaving it overnight and rebooting .
power supply for shield is rated at 5 volt two amps, uno is powered through usb
. i have tried sending an AT&F command to reset to factory defaults
what have i missed? it almost seems there is some serial communication issue. there is just no response in serial monitor .
is there another serial program that might pick up any response at all at any baud simultaneously? though i guess this will just confirm the hardware serial side of it and not the software serial.
i may be looking at a new shield but am a bit gun shy with this unit if it fails just sitting on a shelf.

Hi Richard,

Was there anything that has changed between when you were running the project initially and when it was left on the shelf? Also, is the network that you’re connecting to the same as the original project? Another interesting way to check whether the board is correctly connected to the network would be to use a scanner such as those that Microsoft personally recommends at the link below, you should be able to find the board without issue if it’s connected properly. Also if you have another device to test it against to see whether it’s the board or the connection to the network that is failing for that application that’d be very useful in troubleshooting too.
(Should be relevant info here for Windows 7 too)

All the best with it!

Core Electronics | Support

G’day Bryce
after much hair pulling and teeth gnashing i have found software serial to be the culprit.
it just doesn’t cope with the high baud rates on my computer(s).
with a little persistence i can manage to change the baud rate(i think it changes) manually through software serial(AT+IPREX=9600). however due to the code on the products wiki setting the software serial baud at 115200 i cant communicate with any further after this. if i reload the uno with a script that specifies a lower baud then i cant communicate with it to change the baud rate in the first instance.
i tried altsoftserial but it seems to have trouble compiling on a uno- something about falling edges.
any thoughts?

after following the link and re reading your reply i’m not quite sure you understand my question/query/trouble. this board has very little to do with printer/scanners and or computer networks. the network i refer to is the mobile phone network. but thanks for having a go.