DFRobot Speech synthesizer

I recently purchased the DFR0760 to play with. I have hooked it up to a mega2560 running the I2C example from the github repositry and nothing happened. I then uploaded the I2C scanner sketch, ‘no device found’.
I checked the switch was in I2c position, checked the continuity of the switch (it feels a bit dodgy but measured ok), checked the continuity of the suplied cables, all good. I plugged in an LCD module with an I2C backpack, works fine.
Plugged back in the DFRobot module and nothing. I checked the voltage on the I2C voltage level converters and measured 3.3v on what I took to be the Emitter and Base terminals and 4.87v on the Collector so the board is getting voltage and the regulator is putting out 3.3v, also the modules I2C lines are connected.
Any thoughts what else I can try?


1 Like

Hi Paul,

Welcome to the forum :grinning:

I can’t think of any obvious reason why the steps you’ve outlined wouldn’t work. Can you post a photo of how you have everything connected? It never hurts to have a second set of eyes check.

1 Like

Sorry, don’t have a photo. I just tried UART mode with a 5v ProMini, same result. :frowning:

Hi Paul,

Ok if it’s doing the same with a different microcontroller and UART then it may be a hardware issue.
Can you post a photo of how you have everything connected just so we can double-check it isn’t something out of left-field that might be causing the issue?

Once we’ve confirmed there aren’t any issues we can spot in your photo we can try and replicate your testing setup here with units from stock and confirm if it’s a hardware fault that’s causing your problems.

1 Like

Sorry it’s taken a while to reply. I bought a brand new Nano from Jaycar down the road to try. I used the I2C scanner program and managed to at least get the unit to reply with a hex address of 0x40. When I uploaded the sample speech Program from DFRobot, I briefly heard a short duration buzz when I held the unit up to my ear (very faint sound), but nothing else. I’m attaching some photos. The photos aren’t all that great, but you can see my connections on the Nano. The screen shot shows the IDE of the program and the Serial monitor from the I2C scan showing the scanned hex address.


Hi Paul,

The scan returning the correct address (more than once) is very reassuring!

If you have a multimeter handy I’d try measuring the voltage on the 5V pin when the module is trying to output some sound.

If you have a spare UNO handy it might also be good to check with that! The 5V regulator is quite a bit beefier.

Unfortunately we dont have one in stock to test against so cant confirm if anything is hooked up incorrectly - it’s also a pretty complex module so something in the firmware might be messed up.

Let us know how you go with the troubleshooting steps above! If you dont have any success feel free to reply to your order confirmation email :slight_smile:


The voltage does drop to 4.5v but that should still be enough to work. My USB voltage/current device suggests it’s only drawing 60mA including the Nano. Nope I think this one is defective. Can I return it and get my money back or a credit, maybe?

1 Like

Hi Paul,

Thanks for checking those voltage and current levels, they seem to be within normal ranges.
If you can reply to your order confirmation email with a reference back to the troubleshooting you’ve already done here we’ll get the process underway for an RMA/credit and get this sorted out for you.