IO Expansion HAT for Pi Zero/Zero W DFR0604

I bought one of these a couple of years ago and have only just got around to building with it. Unfortunately when attached it does not show up with i2cdetect. I see that other people have reported similar issues with the version for full sized rpi boards. I have not tried using GPIOs or PWM yet but others report it is only the Analog pins that don’t work. Anybody tried using this board or any suggestions why it does not show up?


Hi John,

I’d be sure to check that I2C is enabled in Raspi config.
A quote from this guide:I2C with Raspberry Pi - Tutorial Australia

To do this, go to the Menu → Preferences → Raspberry Pi Configuration, then under the ‘Interfaces’ tab, select I2C as ‘enabled’, and then reboot.

1 Like

Yes, definitely enabled, I use a lot of i2c devices.

1 Like

Hi John,

Very sorry about the delay! Were you able to get it working?

Taking a look through the GitHub it looks like you it might not be responding to the i2cdetect command just because it isn’t responding.

If you run the following in Thonny, do you get any addresses returning anything with i2cdetech?

from DFRobot_RaspberryPi_Expansion_Board import DFRobot_Expansion_Board_IIC


Thanks Liam, tried this and get the response:

Traceback (most recent call last):
File “”, line 1, in
ImportError: cannot import name ‘DFRobot_Expansion_Board_IIC’

If I try import DFRobot_RaspberryPi_Expansion_Board

and then try DFRobot_RaspberryPi_Expansion_Board. and use tab to show options, Thonny replies with :

"Could not import jedi**”**

No idea where this comes from!

Any ideas?

1 Like