Find IP address of NAVIO2 attached to RASPI3+

Torn out all my hair now tearing up scalp…!
Tried Nmap which easily finds my laptop and desktop and displays " No targets were specified, so 0 hosts scanned." when searched for " navio" and " navio2"
Trying to link Mission Planner to the NAVIO2 but without IP address it’s not possible

Hi Ian,

I’m not familiar with that product, but maybe someone else on here has used it before. If that fails, I see that you are already on the NAVIO forum, hopefully they can help you find a solution.

Good luck and let us know what you find!

If you are using Windows, perhaps try arp -a when the RPi is connected/disconnected. Once you know the IP address, you’ll also know the MAC (and then you can assign a static IP on your router).

All else fails, connect the RPi’s HDMI to a monitor, along with a USB keyboard. Open terminal, and run

hostname -I

hi Graham…

Thanks for the reply…
I tried both of your suggestions and both returned a blank…

The RPi/NAVIO refuses to be recognised in my router WIFI devices, in Nmap ZenMap and Putty

I have connect the RPi’s HDMI to a monitor, along with a USB keyboard. Opened terminal, and run hostname -I
It returns a blank

Weird. If hostname returns no value then something is likely wrong with the network config on the device.

Might be worth trying a vanilla copy of NOOBS (Raspbian) to isolate if it’s config related, or hardware related.