Glowbit desktop audio-visualiser (project)

Trying to get the Glowbit desktop Audio-visualiser (from site projects) working. Following tutorial trying to oled working … getting error on line 43 of using Thonny.

Glowbit responding to sound on pc with main exe but now only have 3 lines of leds showing.

1 Like

Look for typos or syntax errors in your code. Review the code on line 43 of carefully to make sure that it is correctly formatted and that there are no errors or typos. You may also want to review the code from the tutorial to see if there are any differences between your code and the tutorial code.

Hi Roin
Also be wary of the copy and paste method of transferring sketches. On several occasions I have done this with Arduino complete or part of sketches with no success yet when I typed the same sketch or part it worked perfectly. Some sinister goings on with the copy and paste method.
Cheers Bob

1 Like

Yes had cut and paste issues before….will retype cod and see what happens

Hi Robin,

Whenever you get an error and are seeking help, please post the error text exactly, or a screenshot of your editor, so we have all the info you have. Also a photo of how you’ve got things physically connected is helpful also.

Keen to get to the bottom of this with you!

Not exactly the same as the glowbit 8x8 audio visualiser tutorial but I thought it should work

Also I seem to now have problem with the glowbit 8x8 in that it’s now not showing all the leds …testing it with matrix.wheel

I have finally found the problem to getting the project working.

It says on the tutorial that SCK goes to GP0 and SDA goes to GP1 but found out from another tutorial that SCK goes to GP1 and SDA goes to GP0. When I did this, that part of the project worked with text on the display. I also noticed that it says that VCC is to go to VSYS where the pic shows it goes VBUS.
And one other thing when starting the ‘av_windows.exe’ program to get it all linked and working . I needed to reset the Pico first.

All in all the project is great, though I do now still have a bug with the Glowbit 8x8 not showing all the LEDs…not sure how that happened…

1 Like

Hi Robin,

It’s either a software problem where for some reason your Pico isn’t talking to LEDs above that index, or it could be a hardware fault, where one LED has failed, and therefore isn’t lighting up or passing on the data to the next one in the chain like it should.

Have you tried the basic code in the setup guide to eliminate any chance of errors in the rest of the code?

Let us know how you go, if it looks like a hardware fault we’ll handle the rest via email.

Yes I have tried the basic code. That where I took the pic from


1 Like

Hi Robin,

Looks like this may be a hardware fault then, shoot us an email to the address on our contact page, and we’ll sort you out: