High Pitch Sound from Pi 4B, Using Official PoE+ HAT

Hi All,

I just bought a Pi 4B and the latest PoE+ HAT, connected it all up, plugged it into my switch, Pi came to life, but it’s giving off an awful high-pitch sound. This doesn’t seem normal and I am using the official PoE+ HAT, so I am thinking something isn’t right with the PoE HAT.

It only makes the noise when it’s idling. When it’s booting up it seems to be fairly silent as the CPU is busy.

Link to video of the sound: Video Link

Help?

Thanks!
Stef

6 Likes

Hey Stef,

You wouldn’t happen to have your Pi connected to USB C power as welp would you? I noticed there’s a warning about that on Core’s product page.

6 Likes

Hi Oliver,

I read about that issue, but it’s solely powered by poe, no other cables connected. I’ll upload a video shortly for everyone’s enjoyment of that horrid sound… lol

6 Likes

Looking forward to it :stuck_out_tongue:

It could also be just because it’s a switchmode power supply. Most switchmode supplies make some high pitched noise, but it’s very quiet because they’re inside a plastic housing, whereas the POE hat is a bare pcb.

Here’s a good write-up from digikey on some technical details:

7 Likes

Hi Oliver

If that is the case it seems like a half designed device. I think this problem has come up before but I don’t remember the result.
In the past I have carried out repairs in a VCO out of a synthesiser. Steps were taken to prevent microphonics which entailed a glob of some rubbery material stuck on critical components to suppress any mechanical vibration. Maybe something like that such as a silicone product daubed liberally on components like inductors (probably the most logical source of audible noise) etc might help.
Cheers Bob

9 Likes

Hi All. I have updated the OP with a link to the video I recorded this morning.

6 Likes

Ok, that doesn’t sound right. I was expecting more of a quiet whine like a CRT. Definitely seems related to current draw.

What standard does your PoE source device comply with? This could also be the issue if it’s not standards compliant (esp. if it’s just a passive injector).

4 Likes

My PoE source is a first generation Ubiquiti UniFi 16-Port 150W Switch (Model US-16-150W), which their official documentation states is 802.3af/at compliant.

5 Likes

This is a bit of a worry. I can’t hear anything except the device being moved on the table and keyboard noises. Even with my hearing aids on. Age maybe ??? But I suppose one advantage is that if I can’t hear it I would not have anything to worry about.
Cheers Bob

6 Likes

Looks like it is a known issue with the PoE hat. It was observed with USB powering up of the Pi. In your case, the UniFi being auto-sensing regarding the PoE output, probably (my very uninformed opinion) producing the same effect. Try a different ethernet cable and if it goes away (the only nonsensical solution I can think of).

4 Likes

Indeed, with the UniFi Switch, I can configure the port to be POE/POE+ or Passive, but not tell the port to just be POE+. Not sure if that might be a cause or not.

I thought of the cable being the issue also. I tried a different Ethernet cable (0.3m length) directly connected the switch, removing the cabling in the walls and the 3m patch lead I have on my desk as a cause (one I used in the video), with the same outcome unfortunately.

I have heard back to CE support and they have asked me to send the whole unit back for testing. I will give you all an update when I hear more from them.

5 Likes

Hi All
This device seems to be sitting on a bare table. I suggest this because I can hear it being moved around quite clearly. Could this be causing the table to amplify the sound at all . Try sticking the device on rubber feet or some other softer surface and see if there is any improvement.
Cheers Bob

3 Likes

Hi Bob,

Thanks for the suggestion. I can confirm the device does have the rubber feet installed in that video and it makes the sound with the same volume and tone even when it’s just in my hands.

2 Likes

Hey Everyone,

Thanks for posting!

Hackaday has an interesting article on this I’d recommend checking out. Some of the older (closer to the original) models of the PoE+ HATs are still around, and occasionally these teething issues manage to make it through the manufacturer QC

The problems that have been identified are: high temperature, high power draw from the HAT itself at idle, the 1.2 amp USB limit, a long bolt that contacts the camera connector, a louder fan, and odd behavior when powering the Pi and HAT over the USB C connector.

As Oliver mentioned earlier, the coil whine from that inductor does get quite loud when it’s also being powered by another source such as USB-C (which I can see isn’t the case here, but thought I’d mention the reasoning for it). The Ubiquiti UniFi 16-Port 150W Switch you mentioned shouldn’t be too noisy of a power source to use, but from my experiences with these HATs that often will have quite a significant impact on the volume and pitches of the noise you get from that coil:

Switchmode power supplies that aren’t enclosed are fairly notorious for this, it seems that the QC on your PoE+ wasn’t quite up to scratch from what I’ve heard, unfortunately.

The Support team at Core Electronics should be able to sort this out for you. If you reply to your order confirmation email we’ll be in touch from there to organise a solution :smile: (If you already have we’ll be in contact shortly)

5 Likes

I was about to create a new thread but thought I’d chime in here to report that I’ve also seen excessive noise with the new PoE+ hat and Raspberry Pi 4. Especially when the Pi is shutdown, I’ve measured coil whine at levels up to 62dB(A) at 30cm. It’s unacceptably loud.

Power source is a Cisco SG350 switch. No USB power connected and no other hats installed. I’d love to learn if this is commonplace or if I’ve just got a bad sample.

5 Likes

Hi Andrew,
Welcome to the forum :slightly_smiling_face:

We’ve found there is quite a bit of variation with the PoE+ HAT even within the same shipment. It seems to be an issue the Pi Foundation hasn’t yet solved. Some will work just as you’d expect with the fan being the loudest component, others will be unreasonably loud.

If you got the loud PoE+ HAT you have from us, just reply to your order confirmation email and we can go through the RMA process to get a replacement or refund sorted out.

2 Likes

Thanks Trent, appreciate it

2 Likes

Just thought I’d add an update here for anyone that finds this thread going forward. Swapping out to another PoE+ hat led to a significant improvement in terms of coil whine\noise. There is still some very faint noise but once in an enclosure would be negligible and certainly acceptable for most applications.

1 Like

Hi Andrew,

Thanks for posting in this thread as it gave me a reminder to post an update. Core electronics replaced my HAT with a new one and my coil whine is gone. I get a quick high pitch sound when it first powers on for a split second and it’s gone while it’s running. I call that a win. Just a faulty HAT is all I had and the team sorted it quick and got a new one shipped out as soon as they could.

Stefano

1 Like