Interfacing DFRobot Max30102 with Raspberry Pi 4 B

Hello, I am trying to connect a DFRobot Max30102 Oximeter sensor that I’ve purchased form Core Elec. to Raspberry Pi and set up an I2C interface. I have followed tutorials to connect the 3.3V, GRND and SDA & SCL pins between them. When I run a detection code (sudo i2cdetect -y 1) on Raspberry Pi I can see the 57 channel being picked up but the sensor LED lights are not on. I’d appreciate any help in troubleshooting this step. Thank you

Hey @Sahar271030, Welcome to the forums!

From what I can get out of the documentation for this sensor it seems like the state of this LED is configurable and can be changed with your code.

Have you tried running any test scripts on the sensor to see if it works as expected? Its a possibility that this LED will turn on as required when you execute your code.


Hi Sam,
Thank you for your reply. Yes, I thought the same and have tried running test scripts, and receive no response form the sensor.

Nice job, lets see if we can isolate the problem.

You mentioned that you had followed a few tutorials to set this up. Would you be able to let us know what ones specifically so we can check your completed steps.

Photos of your physical setup and wiring wouldn’t hurt either to check that for issues.