Leonardo proving useless - Cannot upload to it, from a linuxOS

Hi All,
My recently-arrived Leonardo (arduino clone) is steadfastly refusing to allow any IDE sketch to be up-loaded to it. It seems to be a major problem encountered by many people out there…

I have tried all of the main suggested solutions, most notably holding down the reset button until the sketch/code is ‘Uploading’ as indicated on the IDE screen. Nevertheless, uploads still always fail (I have tried the upload from two separate linuxOS computers, and I have ports and board-type selected properly).

The error is always:
“avrdude: butterfly_recv(): programmer is not responding”
and then
“avrdude: error: programmer did not respond to command: exit bootloader”

This problem really renders the Leonardo micrcontroller board useless for my application, which is disappointing… I had been led to believe from what I had read - including on CoreElectronics - that the one-chip approach to USB communication was advantageous and more streamlined. But this is completely false… the interruptions to USB comms between the board and the computer seem to be a fatal flaw for telling it what to do, ie, actually using the microcontroller.

And even if I could get the “hold reset button down until Upload” strategy to work, it would be an ugly solution and would mean the Leonardo is not usable for applications where pressing buttons is out of the question (like in a chemical environment, in my case).

I guess I need to start searching for a new & functional microcontroller board, but I am interested to hear if anyone has conquered this major handicap for the Leonardo (let alone find it to have any benefits). Can anyone actually use one of these?
Thnx… Sincerely… Julian

Hey Julian,

Sorry to hear you’ve had a few issues with the board.

I will say I’m a little unfamiliar with the errors that have come up though I’ve done a bit of digging and might have some potential solutions.

Check out the tips from this stackoverflow forum post.

Thanks Owen,
Yeah, I think I’d seen that page (among the many I consulted)… but I ran through their suggestions again anyway. Nothing was applicable/worked… however I may have stumbled upon a small victory in that I did manage to upload code a few times while I was powering the Leonardo with a separate 5VDC power supply.
I don’t yet know if this is a persistent fix, and it isn’t particularly satisfying without understanding what might be going on (although it could have something to do with a conflict between power wires and signal lines in the USB connector).
Any views/ideas?
Thnx, Julian

Hi Julian,

That’s an interesting issue. It sounds like the Leonardo may be partially faulty or that the power supply that is being used when the device was being programmed either provided insufficient current or an over-voltage. In either case, we’re glad to hear that it’s at least partially functional at this point in time. If there’s anything that we can do to assist you with the part please email us at support@coreelectronics.com.au and we’ll see what we can do for you. Have a great day!

Core Electronics | Support

1 Like