Lulzbot Mini with Cura 2.6.52 not working?

I’ve got Cura 14.09 installed and happily talking with my Lulzbot Mini.

Installed Cura 2.6.52… installs fine, select Lulzbot Mini, click “Connect”, thinks for a while and then nothing… no control over the printer. Even when the printer isn’t connected via USB it shows as “Connected”

I’ve tried forcing it to use COM5 rather than AUTO but still the same result. Do I need to uninstall drivers from the 14.09 install? Additional steps?

Hi Joe,

I’ll see if @Aidan can chime in on this one, he might know of the specific issue you’re hitting.

right… fresh install on a different computer. Fired up and connected to the printer… only concern is that it is requesting a firmware update but the laptop I’m using to connect isn’t internet connected.

Does the Cura 2.6.52 install have the firmwares packaged up along with the installer?

I also read through some more details on the Cura install page and it says to delete the %appdata%/cura-lulzbot folder, but on investigation, it only contains 2.6 configuration. I would be guessing that there is a mismatch of drivers somewhere. I will download the driver pack as well and try that.

Uninstalled 14.09. Installed Arduino IDE 1.8.1. Installed RAMBo USB driver. Deleted both %appdata% and %localappdata% cura directories. Installed Cura 2.6.52. Still no dice.

I will continue to use the other laptop until I get some more time to debug what the 14.09 installer actually installs

Hey Joe,
I’m terribly sorry for the late reply on this one, I’ve just come across the open discussion on my travels. It sounds like you might need to perform a firmware update on your Lulzbot Mini in order for it to work with Cura 2.6.

The steps are outlined here, but if you try that and don’t get anywhere, send an email off to and they will be able to offer more assistance.

No worries about the late reply, festive period and all that…

I have updated the firmware as instructed but the original laptop still cannot connect to the printer using 2.6.52, I uninstalled everything again including drivers and installed 2.6.63 and still had no luck.

Given I wanted to spend time printing rather than troubleshooting IT issues (ie my day job) I’ve left that for the time being and will most likely just go down the Octoprint route.