Microbit not recognised on Windows 10

Hi, I’ve recently purchased a BBC Microbit, but unfortunately it’s not being recognise when I plug it into my laptop. It’s not showing up anywhere in the File Explorer, and device manager isn’t listing anything.

The device itself appears to be functioning fine, as it powers on with both the battery pack and USB, and it runs through it’s pre-programmed games with no problems.

I’ve tried 2 different cables, including the one I received with it, as well as all 3 USB ports on my laptop.
I’ve also connected it to my wife’s computer using the same cables and it’s recognised no problem.

This leads me to believe the issue is with my computer.

In case it’s relevant, an Acer Aspire 5 running Windows 10 x64
AMD Ryzen 3 3200U with Radeon Vega Mobile Gfx, 2.60 GHz.

Please let me know if you have any suggestions, or need any more information to help narrow things down.



Might be drivers not auto loading in Win10. Have had that on rare occasions.
Could be USB-2 / USB-3 issue.
My laptop has 1 x USB-3 port (plastic part of port is blue) and 2 x USB-2 ports (internal plastic is black).
I have had some USB-2 devices that will not work with the USB-3 port.



Thanks for replying.

Upon checking I also have 1 x USB-3, and 2 x USB-2 ports.
I’ve just double checked all 3 again in case I’d missed one in my trouble-shooting.
Unfortunately I can confirm all 3 ports aren’t working.

Do you have a MicroBit yourself?

My university teacher for cyber security got me interested in getting one, so I ran the problem by him today and he was stumped as well, though he said he’ll look into it over the weekend.
I honestly thought I’d find a solution online fairly quickly, but a lot of sites seem to regurgitate the same trouble-hooting steps that don’t seem to fix the problem.

Hey Darren,

When you plug the board in does Windows make any sounds? In the device manager it might not come up as a COM port but as an unrecognised device. If you have access to another PC it would definitely be worth testing it on that.
Also do you have the V1 or V2 microbit? You can read up the difference here: The new micro:bit V2 : Help & Support

PS: it would also be worth checking our the RPi Pico: https://core-electronics.com.au/raspberry-pi-pico.html


Thanks for the suggestions.

Windows doesn’t make the usual noise when it detects a new input sadly.
I did trawl through the device manager, but no sign of anything, or any unknown devices either.

I have the V2, and I also got a Pi Zero. That’s recognised just fine, I tested it when I ran into this problem. I was planning on starting small with the Microbit, but I suppose until I find a fix I can start tinkering with the Zero.

I’m fairly new to coding, so I’m jumping in the deep end a bit. Would you recommend the Pico for somebody starting out?


Hey Darren,

Hmmm, I’m not too sure about the micro:bit, the Zero can run Python which is simple to write vs C or Arduino.

Yeah for sure, it supports Micropython and setting it up is very simple (the pin functions are spread across all pins so wiring it up is easy as). Plus theyre cheap as!


Hi All.
I suppose the USB ports are actually working aren’t they??? You could try plugging in a mouse or other USB device to check.

You have checked the device manager to make sure there are no little yellow triangles anywhere with an asterisk in them???

I recently had my USB3 port fail. It was a hard drive I had plugged in asking for too much current. I went to Google to find out what could be wrong. I uninstalled the driver and Windows 10 re installed at next start up automatically. Problem solved. I will have to power this hard drive externally.
Cheers Bob
Sorry I just re read your last entry. You apparently DO have other USB things that work so scratch my last glorious trouble shooting effort.
Cheers Bob


Yes, I have a number of micro:Bits. One is V1 the rest are V2.
Just tested a V2 on Win10 PC & Lenovo Laptop running Linux Mint, worked on all ports.

If the micro:Bit works on another PC then the problem is definitely the Laptop.
If the Laptop ports work with other devices then it may be the way the laptop handles a new USB device or other software or drivers that are not letting the micro:Bit install. It can be very frustrating to deal with this kind of stuff and especially when the solution may be quite simple.

The power issue that Bob mentioned may be a reason, but the micro:Bit on its own draws less than 100mA.

When I was working the organisation did not want people installing stuff from USB drives or using USB drives on desktop PCs. The Windows image was modified to stop access to USB drives, the port would only work for mouse type devices. Probably not the issue in your case.

I have used the Make Code Microsoft application to program the micro:Bit. Very easy to use, drop and drag blocks.
For more complex programs I used the Micro Python web application for the micro:Bit.


Hi all.

I’m a new user, so I can’t tag everyone ,but wanted to say thanks all for your help.

I’d like to say we all figured it out, but I sat down this morning to keep working on it and to my surprise it just miraculously started working :sweat_smile: on all three use ports no less.

One of those things I guess.

It reminds me that I had a somewhat similar issue a few weeks ago where my track pad stopped working randomly. It was no big deal as I usually use a mouse, thought I wanted to solve it anyway of course so I Restarted, rolled back drivers, uninstalled, reinstalled them and nothing, but then a few days later it was working again.

Anyway thanks for all your help, and for the suggestions on how to get started with the mocrobit and pi devices. I appreciate it.

1 Like

Glad you got it resolved.
Does indicate Laptop is not 100% with USB ports; due to it happening with different device.
Make sure you back up everything on Laptop in case it fails completely.