Onion Omega - First Time Setup Using the Command Line

Dave just shared a new tutorial: "Onion Omega - First Time Setup Using the Command Line"

In this tutorial, we will learn how to set up the Onion Omega2/Omega2+ for the first time using the command line. 

While the Omega2/2+ has a graphical setup wizard and a web-based GUI called the “Console,”  we have found both to be suscept…

Read more

I have powered on my Onion-Omega2 and attempted to set it up via command line, following the instructions given in the Core Electronics video.

I got as far as completing the “wifisetup” steps . The unit responded with “Restarting the wifi-manager …etc…”, but never seemed to proceed any further . The PuTTy session was still intact. When I tried the next step “oupgrade” , the response was unsuccessful, something like "… no Wifi connection … " . I switched it off and tried to set up wifi again.

Now each time I switch the O-Omega2 on, the amber LED would come on flashing rapidly for about 10 sec, then keep flashing at a slower rate, forever. The flashing no longer stops . I can still connect with the O-Omega2 via Putty, and attempt to do “wifisetup” again, but that’s all that I can do with it. I tried the ping command, and it was unsuccessful . There is nothing wrong with my home Wifi as all my computers and phones can access the internet via Wifi without any problem .
I’ve had many attempts with the O-Omega2 right next to my wifi router, still with no result . (BTW, as it happens , the password for my Wifi network contains many upper-case letters. Would that cause any problem for the O-Omega2 ?)

Any suggestion would be much appreciated.

Many thanks,

Best regards,


As advised by Sam from Cores, I searched the web for some clues. The following link is relevant to my problem:

To make a long story short. I fixed my problem by editing the Omega2 wireless configuration file using this command:
vi /etc/config/wireless

I changed the following parameters, which is particular to my router:
AES changed to TKIP
WPA1PSK changed to WPAPSK

Then I used the command “nr” to do network reset . After waiting a while (until the PuTTy session dropped out ) , I reconnected and tried the ping “google.com” command.

Now my Onion-Omega2 finally worked with my wifi router .
This seems to be a common problem with the Omega2. Probably due to the fact that there are so many different types of Wifi router in the field . However, it can be solved with a bit of investigation and persistence


Great intel, thanks @Manh55612