PiicoDev Micropython on Pico W - EIO

G’day folks,

I’ve got a bit of a problem using the PiicoDev RFID and OLED boards. Namely - the I2C devices never show up in a scan. I’ve tried I2C and SoftI2C, neither of them work. I’ve tried two different PiicoDev cables - neither work. Two different PiicoDev devices - neither work. (I’ve got the Pico W plugged into a PiicoDev LiPo Expansion Board for Raspberry Pi Pico | Core Electronics Australia)

I don’t have a known working I2C device handy (or a scope) to check exactly what’s happening, electrically. Any help? Is my PiicoDev board DOA? Have I missed a step somewhere?


Hi Morgan,

Welcome to the forum. This isn’t an ideal situation but we’re here to help. Can I ask which PiicoDev devices you are using?

If you’d also like to send a photo of your set up that always helps us rule out some possible issues.

1 Like

Thanks Jack. I’m using the RFID module and the OLED screen (SSD1306). Though I’ve also tried them one at a time, like shown here.

The code I used to scan i2c is

import machine

# Create I2C object
i2c = machine.I2C(0, scl=machine.Pin(9), sda=machine.Pin(8), freq=100_000)

# Print out any addresses found
devices = i2c.scan()


if devices:
    for d in devices:
1 Like

Hi Morgan,

Thanks for sending those through!

The Pico W seems to be around the wrong way, the micro-USB ought to be next to pin 0.

Let us know how you go once its spun around!

1 Like

oh ffs :man_facepalming:

1 Like