PiicoDev Potentiometer (Rotary) (CE08463)

This is a placeholder topic for “PiicoDev Potentiometer (Rotary)” comments.

Add intuitive, analogue control to your project.

Read more

  • Incorrect device found at address 53

Hi, I get the following error when using the rotary potentiometer - I have tried many of them and they all behave the same.

I have used the code from your examples and it does the same.

Otherwise it operates correctly with no adverse issues.

Are you able to shed some light as to the root cause?

I am running this on a pico with v1.19.1 but it also occurs on v1.18.

Any ideas ?

Many thanks

1 Like

Hi Socrates,

If you run the following code with only the potentiometer what appears?
It sounds like some of the address switches might be toggled

from machine import I2C
i2c = I2C(0)

What is the value of the actual potentiometer. Handy to know to work out current requirements…
Any Arduino libraries required??
Cheers Bob

Hello Liam,
nothing happens when I run the code.

I have also tried this version:

import machine
i2c=machine.I2C(0,sda=sda, scl=scl, freq=400000)

print(‘Scanning i2c bus…’)
devices = i2c.scan()
print("I2C Configuration: " + str(i2c)) # Display I2C config
if len(devices) == 0:
print(“No i2c device !”)
print(‘i2c devices found:’,len(devices))
for device in devices:
print("Hex address: “,hex(device),” | Decimal address: ",device)

which reports the following:

Scanning i2c bus…
I2C Configuration: I2C(0, freq=399361, scl=9, sda=8)
i2c devices found: 1
Hex address: 0x35 | Decimal address: 53

So all is normal, the switches are all off.

I also tried this:
from PiicoDev_Potentiometer import PiicoDev_Potentiometer
from PiicoDev_Unified import sleep_ms
from machine import I2C

Initialise the Potentiometer

pot = PiicoDev_Potentiometer(address=0x35,minimum=0.0, maximum=1.0)

and the same thing happens. I have also downloaded afresh copy of the PiicoDev driver just in case…

So still at a loss…

Thank you.