PiicoDev Potentiometer - Getting Started Guide

Michael just shared a new tutorial: “PiicoDev Potentiometer - Getting Started Guide”

This guide will help you get started with a PiicoDev® Potentiometer - an intuitive input device that allows you to easily interact with your project. PiicoDev Potentiometers are available in two flavours: Rotary and Slider. We’ll walk throu…

Read more

1 Like

I get an error “incorrect device found at address 53” when I try the sample code with all default settings. I have tried 3 different pots and same error occurs. I also tried changing the ASW switches to all different combinations and the same error occurs. Any clues? Thanks.


Hey @Tariq206165 - Thanks for bringing this to the forums. This is a bit weird! Just a few questions to help us get started finding a solution:

  • Are you working with a slide or rotary pot?
  • Which dev board are you using?
  • Can you share a picture of your setup?

The pots have ID switches, which are a little different to ASW switches. There should be no need to have any of the switches ON for the example code to work.


Sorry I called them ASW but I meant the ID switches. I tried all combinations of off and on on both pots and the sample code kept presenting that error HOWEVER, it runs and operates the RGB module - there is just two errors for two pots. If I remove one pot, I get just one error…and the code works.

I am using one rotary and one linear pot and the same code as per your intro tutorial to the pots.
I am wired differenty though. Pico - RGB module - rotary pot - linear pot. This should not make any difference however I have tried rearranging items and changing the IDs. Thanks.


Have you successfully run the simpler Reading Values & Changing the Scale example?
If you’ve skipped to the end, try this simpler example first - it may reveal the problem.

To confirm, each of the three devices in the Multiple Potentiometers example has a different ID switch setting, as shown by the example code.

  • One pot has all ID switches OFF
  • The other pot has ID:1 ON
  • The RGB module has ID:2 ON

Each switch that is ON shows as a 1 in the id list

colour = PiicoDev_Potentiometer(minimum=0, maximum=1,   id=[0,0,0,0])
brightness = PiicoDev_Potentiometer(minimum=0, maximum=255 ,id=[1,0,0,0])
leds = PiicoDev_RGB(id=[0,1,0,0])

Hi @Michael, when just one pot is used, the message does not occur and the code runs. When two pots are connected, the message occurs and the code runs. I have configured the pots and RGB module as you described. The code runs and the pots reposnd so I am just going to overlook the message. Thank you for the fast response.


Hi, I got mine to work changing the id of the RGB
leds = PiicoDev_RGB(id=[0,0,0,0])
I know it now has same address as the Pot but it all works now
Also the RGB only has two toggle switches.

1 Like

I got the same error as @Tariq206165 when first using a slide potentiometer, no other devices connected. “incorrect device found at address 53”

After some investigation, I believe it is caused by an incorrect address in the driver software.
_REG_WHOAMI = 0x01.
It should be _REG_WHOAMI = 0x11 as specified by the GITHUB page.
When I changed the address the correct Device ID was returned.
In my case 411 which is the slide potentiometer.


Tested with Rotary, and 379 was returned. Nice, now no error.


I have pushed an example program to GitHub that reads the slider value in the Arduino environment: GitHub - DingoOz/piicodev_slider_example: Example program to read values from the Core Electronics PiicoDev Slider


Hi @Nigel164388 - this is great! :smiley: Awesome you took the time to dive into our driver and find the salient details. For anybody else looking to create their own drivers for an I2C device, this is pretty much where you start :kissing::ok_hand:

1 Like