Pyboard v1.1 serial repl unresponsive

Hi All, just getting my feet wet with the Pyboard v1.1.

When I connect to the Pyboard through Putty, the putty interface is unresponsive. The cursor does nothing, the keys do nothing, the return key does noting.

Im running windows 10, the drive shows up as a removable storage as usual. I have loaded some code into that works as a tilt level and works properly as expected.

I installed the unsigned driver from the onboard storage as described by temporarily disabling the windows bits and this completed as expected.

I tried on two computers with the exact problem so I guess at least its repeatable.

Is anyone able to suggest a method to get the onboard repl going or another tut to get it operational through the onboard repl.

Many thanks in advance,

Mark Ando

SOLVED on windows

I like others, probably have loaded some code into and got something running. I then tried the next more complicated serial connection with putty. This is what was causing the unresponsiveness in the putty window.

I resolved the issue by both:-

  1. clearing the contents of the file so nothing is running
  2. pressing CTRL-C in the non responsive putty window once connected, to keyboard interrupt the running program

The repl >>> appeared in the putty window in both situations :slight_smile:

It appears that on windows, the serial connection wont give a repl response if the cpu is busy.

I hope this helps some other newbies, and I cant believe this is not in bold red on the serial connection instructions.

Mark Ando

1 Like