Core Electronics Forum

Xbee 3 wireless link between F9P/RTK2 GPS receivers

I want to send RTCM correction messages from the Sparkfun F9P base to rover via Xbee. I achieve RTK fixed mode when using a wired connection, so I know the two F9P’s are correctly configured per Ublox’s Moving Base Application Note. I have tried without success to replace the wired connection with wireless between the base and rover . The Xbee 3 is my third attempt.

Per Sparkfun’s tutorial, I configured my two Xbee 3’s firmware to the legacy 802.15.4 protocol. I set the Xbee 3’s baud rate to the F9P’s, namely 115200. Other than change the PAN ID, I made no other changes to the XBee 3 default settings. My two Xbee 3 modules are talking to each other via Sparkfun Explorer adaptors when I type in XTCU console log.

My multimeter indicates about 3.3V at the F9P UART2 TX pin which outputs the RTCM messages. However when I connect this output to the Xbee 3 DIN pin, there is no data appearing on the XCTU console log.

Could you please help me set up this wireless link between the pair of F9P receivers.

1 Like

The problem was solved by simply connecting the Xbee’s directly to the F9P GPS module, instead of via the Xbee Explorer USB adaptor! I don’t understand this, but now my two RTK receivers have a good fix with cm level accuracy. Although I can’t view the data flow in the Xbee’s XCTU console, I am able to on a summary level via the GPS U center software.

1 Like