3.5in LCD installer script failing

I recently ordered this 3.5 inch display but the installer script (curl -L http://coreelec.io/2q | bash) fails to work on a fresh Raspbian Stretch install. I get an error message “raspberrypi-kernel was already set on hold.” then the SSH session is closed. Any tips on troubleshooting this? I’m not quite sure where to start sorry

edit: A bit of searching revealed quite a few people having problems with a 3.5in display on newer kernels, however i’m at a loss now because the display i received is entirely unbranded lacking version numbers/etc (it’s different compared to the one on the product page). I’ll give a Raspbian Jessie install a try.

Hi Emma,

What model Raspberry Pi are you installing on? I think that the drivers for these displays were created for specific Raspbian installs. Our installer script is most likely designed for a NOOBS install. I found some links to other ways to install it, but they require custom system images. I should point out that this is not for the same brand screen so they may not work. Ill look around for some more info for you:

for Raspberry Pi 2:

for Raspberry Pi 3:

for Raspberry Pi 3 Modle B+:

or refer to configure it by this link :

Here is another link to checkout for installing generic LCD screens:

Thanks a lot for the help :slight_smile: I tried the image you linked on my 3B+ and it worked after a reboot. Will read up on the generic install a bit more in case i have more problems in the future.

1 Like