4x4 button pads with breakboard not working properly

I recently purchased 4 sets of 4x4 button pads with corresponding break boards and I’m having trouble with two of them. On one of them a single button is not working and another an entire row. I’ve tried replacing the diodes and it hasn’t fixed them. Any one know of a possible solution?

Hi Mitchell,

Which product are you referring to? http://core-electronics.com.au/search/?q=4x4+button

Hi Mitchell,

I’d check for continuity along the traces just to confirm that everything is connected up the way it should be, and perhaps double check connections, and trying one button at a time.

its wired up correctly but there is still no continuity, as i said i even
removed the wiring and diodes and checked again. Still no good.

So you tried testing for continuity along the PCB? from the trace where the buttons make contact to the pins can you find where the break in continuity is?

From the board one appears that its at the first button along the fourth
column and the other its next to the third button in the third column

Ok so you’re measuring with a multi meter from the pattern where the button contacts, to the output pin?

It’s unusual for a board like that to have some continuity issues. Shoot an email through to support@core-electronics.com.au and we can go from there.

Yeah that’s where I have been measuring from