Adafruit ESP32-S3 TFT Feather - 4MB Flash, 2MB PSRAM, STEMMA QT (ADA5483)

This is a placeholder topic for “Adafruit ESP32-S3 TFT Feather - 4MB Flash, 2MB PSRAM, STEMMA QT” comments.

We've got a new machine here at Adafruit, it can uncover your deepest desires. Don't believe me? I'll turn it on right now to prove it to you!..

Read more


Really powerful microcontroller for the price, as always, Adafruit documentation makes life easy.


Hey Sebastian,

Welcome to the forum. Thanks for posting, if anyone has questions about the Feather feel free to add them here.

1 Like

Does Core electronics have a suitable programmer for the ESP32-S3?


Hi Luke,
The S3 has a built in USB to UART programmer, or you could use an external one such as a CP210x or ESP-PROG.

1 Like

Hi Liam, thanks for that info. Yes, to give some context, I was quite successfully using the built in programmer (with the arduino IDE), but it just stopped working out of the blue (maybe performed 30+ sketch uploads this way). I tried resetting the firmware to factory settings etc, but havn’t had any luck so far.

Strangely enough, (or maybe not strange at all!) the circuitPython firmware still works fine on it, but of course this uploads just like a USB flash drive (rather than using the internal programmer i assume?).

Anyway, my thoughts were that I still may be able to write to it with the arduino IDE using a programmer. I have some USBasp programmers, but apparently they’re not compatible with the ESP32-S3.

Nonetheless, I’ll check out your recommendations. Thanks again!

1 Like

Just a quick update.
I was able to successfully upload a sketch using Arduino Cloud with the online IDE.
After this success, I tried to use the standard Arduino IDE and can now upload sketches again.
Unusual circumstances, but happy it’s resolved :slight_smile:

1 Like