Adafruit ESP32-S3 Reverse TFT Feather - 4MB Flash, 2MB PSRAM, STEMMA QT (ADA5691)

This is a placeholder topic for “Adafruit ESP32-S3 Reverse TFT Feather - 4MB Flash, 2MB PSRAM, STEMMA QT” comments.

Like Missy Elliot, we like to "put our [Feather] down, flip it and reverse it" and that's exactly what we've done with this new…

Read more

I bought the Adafruit ESP32-S3 Reverse TFT Feather and am having trouble getting it to work properly.
I have tried loading the graphicstest_feather_esp32s2_tft sketch but there is no output either on the screen or via the serial output. Simple, serial output only sketches work. I know the screen works because the firmware.uf2 FTHRS3BOOT screen shows if I press reset twice.
Is there something I’m missing?

1 Like

Hi Rob,

Sorry to hear you’re having issues with that display. Could you please post a photo of your hardware showing how everything is connected? Since some sketches will partially work it may not be a hardware connection issue but it’s always worth ruling out the simpler things before things get too involved.

Hi Trent,
I simply have the board connected to the PC via a USB-C cable. The cable works with everything else, including another ESP32-S3 board.

Photos are attached.


I have been attempting some further troubleshooting - this is only my second project, so it takes some research. Having no luck with C++, and with the CircuitPython screen showing I have tried that route.

Mu editor is working and simple blink type sketches(?) work. When I tried the code from the screen flashes up what appears as static noise followed by text, for a moment, then goes blank.

So I am still at a loss as to what is going on.

Hi Rob,

Sorry to hear your issues are persisting, it is slowly pointing towards a hardware fault I think.

Just to confirm do things change or improve when pressing gently on the screen? It looks like it’s come away from its double sided tape backing, and ribbon connections can be finicky, so I’d like to make sure it’s not that.

Does this happen on reset/power on? or just intermittently.

I think we’re pretty close to RMA territory here, just need to confirm the easy fixes.

Thank you James,
the screen showing static happens intermittently. I can now get basic C++ sketches to run, however the buttons were only working occasionally, but not at all now.

The Feather_ESP32S3_ReverseTFT_FactoryTest.uf2 firmware shows up on the screen, but no longer shows D0, D1 & D2 button presses - I’ve tried a few times.

It would seem that gently pressing the screen may have sorted the screen out, but the buttons seem to be the main issue now.



1 Like

Hi Rob,

Looks like you may have gotten a poorly soldered unit in general.

Reply to your order email with a link to this forum thread and we’ll kick off the RMA process there for you.