Arduino Mega 2560 communication won't upload

I have a genuine arduino mega and I’m getting an error code: failed to load .
I have used this previously on desktop and laptop computers with no problems
with ver. 1.8.5 .
The sketch i’m testing it with is the simple blink example in the ide.
It connects to the USB ACMo port ok but when I load the sketch from the ide it nearly completes
in the status bar, then the error comes up.
Has the bootloader or main chip gone west?
I have tried to reburn the the bootloader using the onboard pins with a usb/programmer device
which has been used on other things and works ok.
The reason i’m asking if it was a aftermarket copy i wouldn’t mind throwing it but being an orginal
trying to save the expense…
Is the unit cooked? :slight_smile:
Any help would be appreciated ,
Cheers albert

Hey Albert,

Hopefully we can figure out what has happened, are you about to post what the content of the error that comes up is?

Cheers Clinton
takes a little while then :-
avrdude stk(500): timeout.

error uploading etc.
That’s about it.
I can identify the board using the IDE Get Board Info
and also get a tick for th USB Port connect ACMO/tty/ etc…
that’s about it?

I found an article that has listed a few of the things that could be causing the STK(500) error give them a try and let me know how you go.

Ok Clinton
I have done that . there is nothing plugged into the board
LED 13 on board lights up apparently according to possible solution
on the instructables, the booloader is ok.
I have tried a different IDE 1.8.5 which used to work…hmm
all the comms look ok I can see the RX Led flashing back
after the sketch fails to load but I never see a blink on the TX Led.
also I’ll keep searching .

Cheers so far

I got caught out by having the wrong serial port selected have you checked that? A lot of desktop PCs have the com header without anything connected to it. I had this problem trying to get a usb to serial connector working. image

Linux user:
Always worked as
Port: " dev/tty/ACMO (Arduino/Genuino Mega or Mega 2560)"

lsusb Bus 008 Device 003: ID 2341:0042 Arduino SA Mega 2560 R3 (CDC ACM)
==> rssi_level:2, rate_bitmap:0x000ff000
[15037.749425] usb 8-1.2: new full-speed USB device number 3 using xhci_hcd
[15037.851803] usb 8-1.2: New USB device found, idVendor=2341, idProduct=0042
[15037.851816] usb 8-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[15037.851823] usb 8-1.2: Manufacturer: Arduino (
[15037.851829] usb 8-1.2: SerialNumber: 7533531343735160A1C1
[15037.852263] usb 8-1.2: ep 0x82 - rounding interval to 1024 microframes, ep desc says 2040 microframes
[15037.898490] cdc_acm 8-1.2:1.0: ttyACM0: USB ACM device
[15037.901330] usbcore: registered new interface driver cdc_acm
[15037.901334] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

All ok sending end :slight_smile:

cheers still searching here: )

Hey Albert,

It sounds to me like you might need to try re-burning the bootloader again. If you have another computer it’s always a good idea to try from another computer.

Cheers as well I have tried 3 all ends with tears Lol.
I’m of the view it’s the boot loader … so I’m guessing I have to try direct to the
Mosi …pins etc … again using other computers think I have tried with 1
see how I fare …
Thanks again
albert the quick :slight_smile:

1 Like