Can't Upload a Sketch to Nano V3.0 Board

Good Evening Folks,

Long story short, I’m struggling to upload ANY sketch to the Nano V3.0. It’s been a very long time since I’ve played with Arduinos so I hope I’ve made a dopey mistake.

I’ve tried all the prescribed troubleshooting techniques;

  • Different USB Cable
  • Old BootLoader
  • Different Nano (bought two)
  • Different Computer
  • Different OS (Mac and PC)
  • Disabling and Re-enabling the COM ports.
  • Earlier version of Arduino IDE

The error message I’m getting is;
" Using Port : COM4
Using Programmer : arduino
Overriding Baud Rate : 57600
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x26"

I believe I have the correct board selected, (Arduino Nano) but just cannot upload any sketch.

The chip inevitably becomes very hot to the touch (near burning) and the RX LED will become red.

Would desperately like some help! Please don’t hesitate to ask the obvious questions, they are likely not that obvious for me.

Kind Regards,


The plot thickness;

Continued trialling some troubleshooting techniques and have somehow got one of the Nanos to work. If I plug in the second one with identical settings, except the COM port (though the same USB Cable, unplugged from the previous unit), I still get the same issue.

I am so out of my depth and am struggling to find any rhyme or reason to this.

Visually, the only thing different between the units is there is a very dull glow from the RX LED on the unit that cannot be uploaded to.

I had the same problem with NANO Every. Finished up using cloud version of IDE which I think automatically detects connected board and configures everything. This worked OK and also seemed to configure board settings and I now can upload from the computer based (offline) IDE OK.

Cheers Bob

1 Like

Hey Will,

If you’ve bought a generic variant of the Nano it might have the CH340G Serial interface. There’s a good article here:

Basically you just need install the correct USB driver.
I’d also suggest dropping the BAUD rate down to 9600 - it shouldn’t affect it, but 9600 is a bit of a fail safe standard.

I was thinking you might be using a cable without the data connections, but obviously not.

If one is getting hot, then it’s probably fried ;(
Is the working one getting hot?
Have you been connecting anything to the GPIOs?

Thank you all,

I tried my hardest working through all potential driver solutions (CH340G etc) before posting but was still having relentless issues. I eventually assumed the first was fried. Unfortunately, after playing with the second over most of the weekend that ended up getting fried as well, though I can confidently say it was user error.

To answer the remaining questions for internet posterity;
@Robert93820 - I couldn’t resolve the issue going through the Cloud IDE, the board wasn’t recognised via the USB cable. I thought this bizarre as the desktop IDE could recognise something was connected, just not capable of uploading.

@Oliver33 - One of the first things I had discovered for troubleshooting and had tried. Any time I had tried to install the driver onto the board the entire computer would provide a Blue screen and crash. Was very bizarre. As for the BAUD rate, everything seemed to be defaultly set at 9600, I am not familiar enough with the Arduino IDE to determine why it was overriding to 57600

@Peter50107 - The working one was functioning ok, until I believe I was a little overzealous seating the unit into a different breadboard and directly powering the unit from a 9V. From that moment, it stopped functioning. With that said, the initial unit was powered via data cable and couldn’t be uploaded to and that was with absolutely nothing else connected to the unit.

I have personally put this all down to inexperience and using non-genuine units. As such, I’ve purchased myself a genuine Uno to build the prototype to later deploy into a Nano.

Thanks again everyone, appreciate your efforts to help.


Something I forgot. Be aware not all USB cables are what they seem. I got caught while trying to connect to my phone, more than half of the cables I had were CHARGE ONLY. That is they only have 2 wires in them. Red and Black. This applies to cables with type A on one end and small flat connectors on the other. Example about 90% of phone charger cables.
I went through all of my cables using the phone comms method and marked the ones that were charge only. Worth investigating.
Cheers Robert93820.

1 Like