Arduino uno wifi rev2 fails out of the box

Received new Arduino UNO WiFi Rev 2 and connected to Arduino IDE on laptop usb.

select board type (only option was Arduino UNO wifi.

Board had onboad led flashing once per second.

tried to download Bilnk Sketch.

Had Serial port error and tried second port option. No change to response.

Sometime later large led next to wifi starts flashing red,green & blue. No attempt to download sketch or apply reset or disconnect and reconnect USB or restart laptop would change the condition.

Note the onboard Tx led never illuminated, the Rx led did flicker momentarily during attempts to down load sketch. Later after google search for solution and further laptop reboot the IDE asked for library update and to install Arduino uno wifi rev2. driver.

After install IDE offered a board type option for the Arduino Uno wifi rev2… Selected this option and ATMEGA4809 and tried Blink sketch download.

The red,greed & blue led stopped flashing and an error message “This behaviour is depreciated and will result in an error in future versions—”.

No rebooting or board resetting will change this outcome. note during sketch download both onboard Tx & Rx leds do not illuminate.

What am I missing? I have been using Ardunio boards for about four years and have not had problems with any of them. I connected an old Arduino uno after this to the laptop and had no problems downloading the Blink sketch to it.

Hi Graham,

Thanks for making a post! I’d recommend having a go with the online editor - that way it should just work straight out of the box:

If you’re using the Desktop IDE, you’ll need to make sure you’ve got the Mega AVR Core installed, and that you’ve installed the drivers. See the getting started guide here for full info:

Regarding the error message “This behaviour is deprecated and will result in an error in future versions—”; you can just ignore that one - it’s unrelated to the issues you’re having.

1 Like

Where did you get the ‘Arduino Uno wifi rev2’ configuration from?

This discussion indIcates it should be from “Arduino megaAVR Boards by Arduino”.
(Sketch is not uploading to to the Arduino Uno Wifi rev 2 [solved] - Arduino WiFi Rev2 - Arduino Forum)


Hi Jeff105671

After laptop reboot and restarting the IDE a message popped up indicating library update and specifically mentioned the Arduino Uno wifi rev2 it asked for permission the install the software so I assume the IDE managed the latest version and correct driver.

1 Like

Hi Graham,

It may have installed the correct driver, but you’ll still need to install the Mega AVR Core manually:

Just a check - are you using the installed version of the IDE or the portable version? If the portable version you may still need to install drivers manually.

My IDE is Arduino 1.8.13 (windows store), I went to the Library Manager and checked for Arduino megaAVR Boards by Arduino and it is not listed. I also looked for Mega AVR Core and it is also not listed. How do I manually install this software or do I need a new version of the IDE?

Hi Graham,

It’s not in the libraries manager, it’s in the boards manager :slight_smile:

Once you’ve got the Boards manager opened you should be able to get it to come up by searching for “megaAVR”


Thanks for setting me strait on that the board manager shows Arduino AVR Boards & Arduino megaAVR Boards but no mega AVR Core.

No worries, sorry for the confusion!

The package you want from the board manager is the one called: Arduino megaAVR Boards

This is what I meant by the Mega AVR Core.


Thanks so I have Arduino Mega AVR boards ver 1.8.7 installed. What next I know you suggested OTA installation and that is something I will explore. However I was keen to get my next wifi project underway and didn’t want to jump into the unknown at this stage. There is still the possibility of a board failure. I need to verify the board is OK and if the OTA is the only way then so be it

1 Like

Hi Graham,

You should be underway now, and right to use the board as normal.

If you need any more guidance, I’d recommend following the Getting started guide:


Thanks for your assistance, this board is working now with simple sketch loaded from IDE.
I will try the WEB IDE when I get more time.
Thanks to Jeff105671 also for your input.
Consider this action closed.



Great, glad to hear it! :smiley:

You’ll have to let us know how you go with your projects!

1 Like