Core Electronics Forum

Nano 3.0 Serial Monitor Stopping after a write

Probably a simple solution, but I have just written a sketch that I have been using for a while now on various UNO rev3’s and NANO Every’s, to my NANO v3.0.

Serial monitor initialises and reads the data as per usual, until I execute a write command and then the serial stream stops and doesn’t resume… The TX light on the board keeps on blinking at the same usual rate though.

The code works and everything works as it should, hardware wise, however just confused why this is happening…

Have written the same sketch back onto the UNO and NANO Every to confirm it is an issue with the NANO v3.0.

Thanks in advance (hopefully someone can shed some light)?

Weird. Got a photo of how you’ve got it wired up, and a copy of your code?

I assume since you wiped your post you figured it out? Was it something to do with dual usage of the pins for Software SPI?

I still don’t know what it was. It’s bloody weird. First day it would partly work, but pause the serial stream after a write. Second day I flashed the sketch on again, many, many times, on different Nano’s. and this time it was not working properly at all. I got it working partly, by commenting out the fram.begin() part in the code. Was working minus the FRAM obviously. Third day I flashed the sketch again and it was all working fine. I flashed it onto 5 other Nano 3.0s and all are confirmed to be working. My Arduino Nano Every worked fine every time (pun unintended lol). So still perplexed what the issue was…

1 Like

Hey,

Welcome to the forum!

How interesting, are you able to put the code up so we can run through it and compare it against the error messages? Also, have you been able to use those boards with other projects sucessfully? The only other place that an issue could be occuring that I can think of is if there’s some kind of issue within the IDE and the way in which the boards are being flashed.

Hi Bryce,

I’m thinking it may of potentially been an issue with IDE more than the board also. So far it’s all fine now. I’m not near the computer at the moment so can’t send the code.

I only use the nanos for these particular projects. So haven’t tried anything else. However writing a simple blink sketch etc to it worked fine. So not exactly sure what the issue was.

Thanks,
Carl

2 Likes