Cannot authenticate to Pi zero 2 w

Hi all, I’m new to Pi so please excuse the dumb questions. I have received a new Pi Zero 2 W unit and updated the boot drive with wpa_supplicant.conf and ssh files so I can see it on my network and able to ssh to the login prompt but when entering the default username and password (pi, raspberry) it does not authenticate. see attached. Using a macbook with PortX to ssh. Any help would be appreciated

Hi Rob,

I know this is only partially related to your issue, but having a Pi set up as pi and raspberry with ssh enabled is a security risk. The next thing I think you should try is setting a new username and password with the Pi imager (you can also configure your network there). See below:

Let us know how you go with a fresh card set up like that, and we’ll see where we need to go from there :slight_smile:


Used the Pi imager and added all the username, new password and other details - imaged and now able to ssh to unit - woohoo! thank you


The reason why I bought the Pi is to stop all Ads. I have tried to run the below command but it looks like the unit cannot connect to the Internet. Please assist.

Hi Rob,

Try adding -v to curl, and remove the | bash and -sSL to let us take a closer look at what is going on (verbose mode)

Alternatively, maybe try the alternative Git method:

git clone --depth 1 Pi-hole
cd "Pi-hole/automated install/"
sudo bash```

Hi James, here’s the output

FW config

Hi Rob,

Very strange that your Pi can see your LAN but not the internet… Pi OS has always “just worked” once initial network config has happened. Usually stuff like this is a problem with the rest of your network, but I wouldn’t know where to point you outside of firewall settings that you’ve already checked.

Maybe take a look at what ifconfig -a has to say about your network configuration?

I’m a little stumped :frowning:

ifconfig -a output

Do I need to add DNS config to Pi? Right the DNS is set to auto on the DHCP on Access Point.

Hi Rob,

I know this will likely sound like I’m pulling your leg, but the only thing I can think of changing at this point is restarting the Pi and router, or your DNS on your Pi to (bypassing the router for DNS). Your Pi will become your network’s DNS server soon, not sure how that will affect it…

Give those a go, not sure where I’d send you after that, networking is hard when it doesn’t work!

1 Like

Hi James, no luck - restarted access point, cable modem, set dns to in dhcpconf and even in resolvconf - restarted pi few times still not internet connection
everything else on the network behaves
where to now?