Pi Zero W - Cant get Wifi working

Hi guys,
Im reaching out for help - my new Pi Zero W is doing my head in!

Ive just bought the essential Pi Zero Kit from Core. The noobs SD card installed without a problem but I couldn’t find out how to switch the wi-fi on - then I read elsewhere that the NOOBS image doesn’t allow wifi (Im not sure if this is true or not??).

OK, assuming its true, I moved on and following the Core Headless tutorial, I downloaded Jessie Lite from the raspberry foundation site.
I put the image on the SD Card, created the empty SSH file and the wpa_supplicant.conf (both in the boot root).

The system boots up but no wifi. Ive tried this many times now, I just cant get the wifi to work. What am I doing wrong?

When I do an ‘config’ all I can see is the loopback address.

I downloaded 2017-04-10 version of Jessie Lite.

I also downloaded the max2play image, same problem - no wifi.

On the plus side, the OS tells me that SSH is enabled - just cant connect to it:)

Edit: I have just googled how to ssh to the Pi Zero W via the USB cable - This works:) But still no wifi.

Please help…


Hi, @Jon13024. That sounds super frustrating :confused:
NOOBS certainly does allow for wifi - my workshop series is built around running raspbian from a NOOBS installation.

The Pi Zero W headless tutorial makes a few assumptions about how your wifi network is setup. I suspect that for your network the wpa_supplicant.conf file is incomplete - There may be other settings you need to include in the file that I didn’t cover in the video.
A thought: wpa_supplicant is only good or WPA secured networks (hence the name). If you’re still on a WEP network I don’t think it’ll work for you. I’d verify this before proceeding.

A test we can try is in the NOOBS launcher. In the screen where you are given the option of selecting a operating system to install, you also have the option to connect to a wifi network to download an install other OSes. Bring up this menu (holding down shift on powerup, or cleaning the SD card and copying NOOBS back on). If you can connect to this network using this menu, but not from your wpa_supplicant settings then that might mean there is additional setup you need to do. If you can’t connect to the network from this menu then there may be something trickier at work…

Either way, let us know how things go!

Thanks Michael,
When I first put in the NOOBS SD Card (pre-installed), I noticed the options at the top of the screen, from memory one of which was wi-fi. I could not select this item, or indeed any of the others on that line.

I’ll re-create a new NOOBS image and try that again.

As for the security Wifi details, all my other machines simply have an SSID and a password.

My feeling is that this is either a firmware issue or hardware driver issue, rather than the wpa_supplicant details. When I ran ifconfig -a I could not see wlan0, only the loopback adapter and later (when I could SSH via USB), the USB/SSH adapter.

I’ll let you know how I get on.


OK, so I downloaded another version of Raspbian Jessie & Jessie Lite and made 2 news SD Card images (My NOOBS version stopped half way when my laptop went to sleep).

Anyway, booted both up and followed this advice:

These are the screenshots from a terminal window from within the new/clean version of Raspbian Jessie (without me adding any wpa_supplicant.conf file) following the diagnostic advice in the above link:

I think this is taken from my original NOOBS image:

These are the same screenshots from within a new / clean version of Jessie Lite:

As you can see, same result across all images - nothing resembling wifi (to my untrained eye)!

Also, in the NOOBS image, when I go into the GUI, the WIFI icon in the top right hand of the bar says:

Hey, Jon
The fact that your desktop GUI is showing no WiFi interface on a fresh install is pretty indicative of a low-level problem.

Please reply to your order confirmation email, linking this post, and we’ll get this sorted out. :slight_smile:

As for the tests you’ve followed, I’ve executed the lusb and lsmod commands on my own working PZW to the following effect. I’m not sure if there’s much information to be gained though, because I’m quite sure the on-board radios are handled by firmware, so they’re not USB devices. As you can see there is no radio listed by lusb.

I’ve posted the results anyway for anybody who cares to reference what a working unit looks like.
Note: I’m connecting via SSH so there are no USB devices plugged into the PZW.

Thanks Michael, much appreciated.

Just a quick update…

The guys at Core were brilliant about swapping my PIW out. I called in on Friday arvo, picked up the new PIW and when I got home… I now have WIFI. Cool.

Thanks guys.


Have exactly the same problem - faulty zero w - no wifi hardware after firmware & os update & all the other ‘try this try that options’ … tried to get support from Core but was referred to here (forums) … now just running around in circles wasting my time.

Hi @Matt37975,

Go ahead and start a new forum topic, let everyone know what you’ve done and lets see if we can get this figured out.