Pi zero not starting

I have never been able to get my pi zero w working.

I have tried moving a micro SD card with everything working from a 3B+ into the Pi Zero w but nothing works when it is in the Pi zero and I dont know why. The green light comes on and blinks. The monitor remains black.

To reduce the possible problems I tested the micro SD using SSH in the Pi 3B+ with no monitor mouse or keyboard and works perfectly and I can see that it logs into my wifi network.
When I insert the same micro SD card into the pi zero it does not show up on my wifi network so I can not log in with SSH.

When I swap it back into the 3B+ again it works. I repeated it several times always with the same result.

Is there something I have to do differently to make it work in the pi zero compared to the 3B+? And if so exactly what do I need to do?

I tried adding IPQoS 0x00 under the ssh_config and sshd_config files mentioned elswhere in these forums. Bit it still doesnt log in to the wifi (2.4g).

Sometimes the green light after a few blinks stays on but the processor does not get hot. Sometimes the green light goes out after a few blinks.

cheers Ian :slight_smile:

I liked the Zero W, being tiny and just right for my robot vehicles.

But the same SD card works on my 3B perfectly, and yet it doesn’t make any of my THREE x Zero Ws work ! Doesn’t boot up at all!

I thought it was a hardware architecture problem. So I just gave up. This was a couple of years ago. I went back to just 3B and Arduino.

Hope you have better luck, update us if you do!

1 Like

There was an issue some years back when the zeros was released (2017 or there abouts) that resulted in the WiFi not being configured.

In the meantime, do you have a USB/Ethernet adapter to use, so you can access it to trouble shoot?

1 Like

No I dont have a usb ethernet adapter. Thanks for the suggestion.
cheers Ian :slight_smile:

Hang on, I thought the zero needed a different installation, because the hardware is different. I always start with the pi0 image. Can you normally take a pi3 installation and put it in a pi0??

The easy answer is to get a Pi Zero noobs. Update it in the zero and then add whatever else to that SD.
Try it…


Have you checked that the two files ‘ssh’ and ‘wpa_supplicant.conf’ are in the ‘/boot’ partition of the SD card?
I think they are used for initial setup/access and deleted.
Also, since the PiZero is a different SOC it will have some differences to the 3B+ (the ‘bcmxxxx’ files that it uses).

1 Like

Thank you friendly forum users for your suggestions. I spent days trying everything I could. I live near Core Electronics and asked them if I could bring it in and try a known working micro SD card but they do not provide that service. I read that the raspberry pi organisation get many returned and only some of them have failed but I dont know how I can return it to them because Core refuse to take it back because I put a drop of glue onto the camera ribbon plug to hold it in after I had used it so many times trying everything to get it working that the plastic clip broke. The glue drop has nothing to do with why it doesnt work. Then I had to wait for new stock to come in and a friend bought one which I tried and it works straight away. I simply plugged in a micro SD card I had purchased with Noobs loaded on it that I had updated in my Pi 3B+. So the answer to my original question “Is there something I have to do differently to make it work in the pi zero compared to the 3B+?” appears to me at this stage to be ‘no’. It should have worked. All my trying to make it work was simply teaching me to not waste my time next time. Core Electronics refused to take it back (due to the glue drop) and gave me an $8 gift card towards my loss.