Connecting Atmel AVRISP2 to Studio7

Hi All

New to the forum so please forgive any stuffups.

I received my new AVRISP2 from Core yesterday and I am having problems connecting to Studio 7.
In Device Manager the hardware comes up under Ports with Prolific USB-to-Serial Comm Port (COM3). The Green LED on the programmer is a steady green.
I open Studio7 and Tools-Device Programming and the only thing there is Simulator. Next, I went to Tools-Add Target. In the Select tool box it shows J-Link over IP and STK500. I selected the STK500 and clicked Apply. The Add target box shows, Select tool : STK500. Prolific USB-to-serial Port (COM3) : COM3. Click Apply. Next I select Tools-Device Programming. In the Device Programming box under Tool, I select STK500 COM3. In the Device box I select ATmega328P. Under Interface it shows ISP and HVPP. I select ISP and click Apply and get message : Unable to connect to tool STK500 (COM3).
In the Detail box below it shows:
Timestamp: 2018-07-12 xxxx
Severity: ERROR
ComponentId: 20100
StatusCode: 1
ModuleName: TCF (TCF command: Tool:connect failed.)

The signature of the attached tool is AVRISP_2, which is unexpected.

It is obviously seeing the tool but I can’t select it!!!

Hope this all makes some sense.

Hi Mike!

Have you installed the recommended drivers for the AVRISP2? The automatically installed ones may not be compatible with Studio 7.

"1.1 Make sure that you have downloaded and extracted the drivers provided for AVR-ISP-MK2, available here:

1.2. Connect AVR-ISP-MK2 to the personal computer.
1.3. You should now have some entry for it in “Windows Device Manager”. If you can’t identify the entry unplug and re-plug the AVR-ISP-MK2 until you are sure. It might be good idea to uninstall any drivers related to the tool, but in most cases if you do everything correctly this shouldn’t matter.
1.4. Right-click over the entry for the cable.
1.5. Select “Update Driver Software”.
1.6. Select “Browse my computer for driver software”.
1.7. Select the bottom option “Let me pick from a list of drivers on my computer”.
1.8. Click “Have Disk” and point to the place where you extracted the drivers from the archive and select “AVRISP_mkII.inf” then click “Open”.
1.9. Select “Next”, and if a warning pops up select “Install Anyway” and after installation close the window.
1.10. Inspect the new entry in “Windows Device Manager” after the driver installation and ensure that there are no errors or warnings.
1.11. Test again.

Hi Stephen

I have attached a photo of the board from the AVRISP2.

As you can see it has an ATMEGA 8535L microcontroller and a PL2303 USB to TTL chip.

In device manager I have Jungo with WinDriver, which I think I downloaded sometime. Under Ports (COM & LPT), there is the Prolific USB-Serial Comm Port (COM8).

I downloaded and tried to install the drivers you sent me, but Windows tells me I have the most up to date.

The link above to the olimex forum shows a whole bunch of connectors. As you can see there is none of them on this board but only the 10 way programming lead.

So none of this has worked.



Hi @Mike96,

If you’ve installed other drivers in the past for similar uses, then they might be conflicting. Perhaps fully uninstall those drivers first.

If you have anything other than this, then the wrong drivers are being used on your PC

1 Like

Hi Graham

I have downloaded the libusb-win32-bin- and unzipped it.
I then clicked on installer_x86.exe. I get the windows unknown publisher and select yes. A window flashes (probably DOS) and that’s it.
I then uninstalled and deleted the drivers from the original location in Device Manager Ports (COM & LPT) Prolific USB-to-Serial Comm Port.
When I plug the AVRISP into the USB it restarts, Windows says installing and when I look at Device Manager I get the same as before:
Ports (COM & LPT) Prolific USB-to-Serial Comm Port.
Not sure what’s going on.

Not very happy with the response from Core Electronics.
From the start there was a problem where I had been sold this piece of equipment and when it arrived it had a CD and User Manual missing. As I am new to Atmel programming (been programming PIC’s for years with the PICKIT’s), I was struggling from the beginning. I ended contacting Core by telephone and was asked to use the forum. I also asked about the missing CD and manual but was told that they weren’t necessary as I could download them. Not very good customer service. My last reply to the forum was 14 days ago and I have not heard anything back from Core.
However I have managed to get the AVRISPII going by doing some research and now I am using AVRDUDESS, which is AVRDUDE with a GUI interface. I bought this thing thinking that it would be easy to use to set up and use, but that alas is not the case.


Hi Mike,

Yep, you’ve had quite the battle! It’s worth opening with: we’re not Atmel, nor are we the engineers that designed this product. We’re doing the best we can to support you in this unique situation.

The device has not come with the CD since around 2016. It’s not missing; it’s now entirely digital/download based. We don’t list the CD as an included part, though we’ll make it even clearer by updating the photos as one of the images could be interpreted as a CD.

It’s become apparent over the last few weeks that your OS environment is different than ours and our tips are not working. We’re everyday makers, much like yourself. We learn through doing, and we’d love if you could share what you did for your environment to get it working.

That intel will likely help others in the future.

Hi Graham/Everybody.
Sorry for the rant but I was a bit frustrated at the time.

Anyway I have managed to get some instructions together and have attached them in PDF format.
Have a look and let me know.

Oh Oh, I can’t upload the file. Any help?


Hey Mike,

Thanks for putting time into this!! Can you email it to and we’ll go from there.

If it’s >10MB then use Google Drive (or Dropbox/whatever). Cheers!

Just sent the files to Support.


1 Like

Thanks for the pdf Mike, looks great!

Using the Atmel AVRISP II with AVRDUDES.pdf (455.3 KB)

1 Like