Dfrobot M0 audio shield - SD card not recognised


Just got the audio shield and matching dfrobot m0 board. However the combo refuses to recognise any sd card I use, they’re all 16gb, fat32 formatted with the official sd card utility.

The sd pin is set to 30, the board is recognised and sketches can be uploaded. I’ve also tried a larger power supply, resets, even made sure that the sd library selected the correct clock etc pins. All sketches tested have been those supplied by dfrobot.

Anyone got any ideas?


Hi T75,

Could you please upload the sketch that you are trying to use? Just to confirm, you are using the Audio Shield For DFRduino M0 SKU: DFR0420 ?

Have you tried formatting the SD cards as fat16?

Yep, that’s the shield! I have tried fat16, no difference.

Here’s the sketch


Hi T75,

Can you confirm that you have tried on more than one SD card? How big are the cards?

Yep, 16 and 32gb, anything smaller is rather hard to find these days! At least two of each

It certainly sounds like you covered all your bases troubleshooting. Hit reply to your order confirmation email and we can get the returns process started.

Talk to you soon!