ESP32 Thing Plus onboard power output issue


my SparkFun Thing Plus - ESP32 WROOM (v2.0) seems to have a problem with its onboard peripheral power (output).
I was attempting to provide 3V power to a Gravity: Digital Relay Module.

The Thing Plus is booting, connecting, configurable, receiving data from two sensors, no problems. I diagnosed the issue with a multimedia after the relay would not power on. The voltage is correct but i am unable to get a reading in A or mA. When i use the multi-meter i see nothing for Amps, and an overload signal for miliamps.

it is a new card, used to upgrade a working system. very strange.

Hi Anthony,

Are you measuring the amps inline from the power input? Would it be possible to send through a pic of your setup?

Liam, I measured the A/mA from what i believed were the relevant sources, originally, I had the relay 5-3V powered by a ‘DC-DC Buck Converter 7-24V to 5V 4A’ powering the ESP32thingplus, a ‘Gravity: Digital Relay Module’ and a ‘Gravity: Analog Current to Voltage Converter’. As mentioned previously, this setup was working on a ESP32Thing with no issues. The amperage from the ESP32 is the only anomaly. Weirdly, the relay should be able to handle the 5V output but did not power up (led) when powered from the buck converter either. The ESP32, and the gravity current converter are working without issue powered from it.

I have a schematic however i am unable to upload/attach images here

I think copy-pasting the error message here will be helpful.

R, no error message for the ESP32. just that the relay wont power on. i get an error message when I try to upload a schematic here.

Hi Anthony
I think first time users of the forum are restricted for a while re uploading things. If Core staff see this in the morning and see fit to do so I believe they will enable your permission or something to allow uploads.
Cheers Bob

Hey Anthony,
Welcome to the forums!

I have got the trust level fixed up for you to upload those schematics. If you could get that done we can see if there is an issue with how everything has been put together and hopefully get the project up and running for you soon!


Blayden, still getting “Sorry, an error has occurred” at 100% upload.

Hi, I am still unable to attach images.

I have narrowed the problem down to the ESP32 card itself. I purchased another bike converter and another relay everything seems works using another card. The problem being I need reasonable Wi-Fi connectivity (which the ESP32ThingPlus has) because the prototype is outside.

Is this ‘other card’ a different ESP 32? If so, what exatly is this other module? If you compare the features of the one that works with the one that doesn’t then you will likely be able to identify the problem.

If you can’t post an image you can post a link to the site where you found the schematic.

1 Like

Jeff, Yes, the one i am having trouble with is an ESP32ThingPlus, the one working (on the bench) is an ESP32Thing. I have another ESP32ThingPlus deployed in the field and its great, working like a champ, but as a less complicated machine.


the above system worked except for the relay. no errors in the log.

At first glance I would guess that you have the relay connected to GPIO33, not GPIO32.

Do you have something to test that pin with, such as a LED with series resistor? That would confirm that the pin you are connected to really is getting the on/off signal.

yes, its connected to GPIO32. I have tried other pins, that was the pin it was working with on the ESP32Thing card. i have some larger LEDs somewhere… but no resistors unfortunately.

the relay ‘clicks’ and operates the valve with the ESP32Thing.

The schematic shows GPIO33.

What was the result with other pins? Can you test the pins with a voltmeter?

yeah, definitely pin32 to start with. that’s just me being a bit sloppy rejigging the schematic in a hurry. some other pins I tried had the same result with the power harness attached. oddly, this afternoon I wired up the relay to get its power straight from from the ESP32 and powered the ESP32 from a DC powerpack (USB) and its working on pin 13 fine. (scratches head). tomorrow i’ll re-solder up the harness leaving the relay on pin 13. The moral of the story might be to breadboard using the same model everything.

SOLVED. the relay only triggers while powered from the ESP32 board. didn’t see anything mentioned in the hook-up guide.

here is the project weatherproofed for field testing. All going to plan I’ll build another three of these to manage the water around my farm.