ESP32 Thing Plus peripheral modules lose power when COM port is accessed via MotionCal

Hi Everyone,

When I connect to my ESP32 Thing Plus’s COM port via MotionCal (I’m having a go at calibrating an Adafruit LIS3MDL magnetometer so I can follow this tutorial) everything but the ESP32 loses power. When I dsconnect via MotionCal, power returns to eveything. When I’m connected to the COM port via Arduino IDE everything has power.

PC → 200mm USB cable → ESP32 Thing Plus C → 500mm Qwiic Cable → Sparkfun ZED-F9P module → 50mm Qwiic cable → Adafruit LIS3MDL magnetometer

I tried using a 50mm Qwiic cable with just the ESP32 Thing Plus and the LIS3MDL, but same problem.

Tried using ESP32 Thing Plus with a 50mm Qwiic cable to the LIS3MDL. Still losing power :pensive:

Hi Jacob,

Can you upload a photo of how everything is connected? Sometimes a second set of eyes may spot a quick fix to your problem.

Good idea, long cable runs with I2C are often a cause of issues as the name suggests “Inter-Integrated Circuit”.
Just in case the 50mm cable is the problem can you switch the 500mm one for it with the ZED-F9P still removed and see if that’s also consistent?

G’day Trent,

Here’s a photo of the simplified setup. Still has the same problem either way.

500mm cable has the same problem. All my other Qwiic cables have the same outcome.

FWIW I’m having the same problem when my Sparkfun MMC5983MA module replaces the LIS3MDL in the same setup as the photo below. No power when COM port is accessed through MotionCal.


Using this example I took:

Lines 7-9
Lines 16-19
Line 25

and inserted them in the appropriate sections of the “imucal” example of the Adafruit Sensor Lab library (Adafruit Sensor Lab → calibration → imucal)

I put line 25 at the beginning and end of the loop section.

Thanks to paulvha

1 Like

Hi Jacob,

Glad to hear you were able to find the issue. Thanks for coming back and sharing the solution in case others have the same issue in the future.

1 Like