Flirc remote dongle

just got mine today where is the software for it i cannot see the device anywhere

i`m using ubuntu on my rpi-4 but still i read the notes on the sales page it speaks of software to set it up yet i dont know where to find it…

Hi Brian,

Was it the FLIRC USB (SKU: CE07072), you were talking about?

I have linked the Support Page for their product and a link to their software below, let us know if you run into any issues with it in the future!


still having trouble getting this to run on my rpi-4 tried all linux methods but still cannot get any response from the commands it appears…

1 Like

Hi Brian, Found this on FLIRC’s website,

see if this command will work:
curl | sudo bash


yes that did work but left me wondering how to run the program it downloaded and then installed also it asked if i wanted to run the utility’s program i answered yes …but it just returned to the prompt…some thing is not right…think i have too look into this with flirc company if i can
as the setup page for linux at least needs work…

i cannot find a correct command to launch the setup program…that i am still yet to find
and the other thing is the help page is quite bland …vrey basic…there were packages that i could not get the rpi-4 to even find…to install .some did and others were just not in any package listing…

support for the product is had to find

i may have to email them if i can…
i am somewhat lost atm…i have not given up on it though…i`m into still quite a few open threads that i need to finish off…thank you…

1 Like

Hi Brian,

Did a bit of digging this morning, hope this helps!

The GUI FLIRC is not terminal based in Linux and as such will show on the programs list in Ubuntu or Raspian. It won’t show up in Libre Elec. If you want to use the remote with Libre Elec the recommended way to do this is set up the remote using a Windows PC (this can also be done for the Linux installs as well) and then move the dongle over to the raspberry pi check out these guides, I found them quite helpful:


i use the ubuntu mate desktop i looked installed and did it over and over.,i don’t have an X86 linux box running at present…there was an download for “arm” so i followed all that…its all in my rpi running ubuntu mate…but i see no program listing for flirc,i run updates the ppas are even in the package lists…anyway i have been doing ubuntu since 2014 when i got into scs.. and so i am quite fluent with linux,,not a guru but we been using the mate desktop since 2015 from mem..before that i was using kubuntu on my X-U3 boards until it seemed not to work something conical changed..dunno what but true arm kde had died and then came kubuntu...oso i should be here this week.. ....Well, the arm instructions are really poor..never tried it on a windows box at all either..because i never wanted to use it for that,,, the guys at fliirc need to do some tending to instructions i believe…but not for me to say… I asked for store credit. It will go towards my rpi-4-8 gig.,.sortry my fan height as well… any just thout that i woyd add this…oh it reached 70 odd deg1s after 5 min or so i dunno 30 lines of text approx sat at 71degs for duration buying the ice cooler this week …maybe the 8 gig but i dunno about that yet…

1 Like

Hmmm, it maybe a distro thing. Just for anyone else who may encouter this problem it may be worth testing it on a windows machine as to date we haven’t had anyone report their results on that