HC-05 Command Mode Problems

Hi Guys,

I have a few of your HC-05 bluetooth modules that I am struggling to get into AT mode. I got about 20 of the modules, half came with the button and half did not. The ones with the button I have been able to get into command mode and get the LED to flash on and off every two seconds or so, but the ones without I cannot.

I have tried everything under the sun, from your tutorial, to every other tutorial on the web. I have tried pulling the EN pin high on startup. I have tried cutting the plastic off and manually pulling pin 34 high on power up, I have even tried soldering my own push button in to use, but all with no luck. I believe I followed your tutorial to the tee, but alas, only a rapid blinking LED.

I would really appreciate any further hints or tricks I could try.


Hi Christopher,

So you’ve followed our tutorial on using that particular Bluetooth module? I used modules with buttons, but also tried soldering a wire to pin 34 to pull it manually.

Would you be able to post a picture of your breadboard setup and your code (if you’re trying to use the EN pin with code). Bear in mind that it needs to be pulled before power is applied to the HC-05 not after.

Thanks for getting back to me Sam.

Sure did, followed that modules tutorial. I have also tried soldering direct to pin 34. Unfortunately, I do not have access to the stuff again until next weekend so when I do I will get a picture and the code to you then. Thanks for you help .

Not a problem Chris,

Sounds like an interesting problem. Post back here when you get it all ready and we can go from there.

Hi Chris,
I’m retired Instrument/Electronics Techo
Mint Linux Sylvia Arduino 1.8.3
Being a liddle budget minded I have also received 2 x HC-05 modules with no button to switch AT mode
soldered a wire to pin 34 and dir to 3.3V I have all correct wiring and code as suggested by
and cannot hit the AT mode.
My serial in the arduino is set NL+CR and 9600 as it is the only speed which i get
acknowldgement of correct characters returned. The arduino code specifies 38400
will only work in 9600. ??? /dev/tty/USB0
Arduino serial monitor communicates fine but no can get into command mode after reading entire internet :slight_smile:
can anyone help in this regard?
BTW using arduino Nano and HC-05 module from Core Electronics

Cheers albert

Hi Albert,

Have you taken a look at our tutorial here: