HC-06 command mode

I have used a number of HC-06 from you before and they have all worked fine. If I recall they were JY-MCU branded. The news ones aren’t. They do register as a HC-06 on by phone however. The new ones I received do connect and can send data both ways at 38400bps but I cannot get them to respond in command mode. The main reason is that I need to set the comms rate to 9600 and change the name.
I have tried different baud rates, shorting the two pads on the PCB that look like SMD switch pads but nothing works.
I am also familiar with the HC-05 and can use these successfully, but this batch of HC-06 has me stumped.
Any clues??


Hi Leon,

Hmm, that sounds strange. I updated our tutorial on using the HC-05 modules after a module without a KEY pin didn’t have a button either, have you taken a look at the updated instructions for entering AT mode there?

Thanks for the reply.
I cannot get the new HC-06 to work the same way as the older versions, so I have to go with the HC-05. I normally just plug the HC-06 into the units we built and they get set up by the firmware.
The HC-05 can be set to work in the units , but I have to program the HC-05 out of the units before installing them.
I’ll put the new HC-06 in the store, maybe I can use them somewhere else.
I could change the firmware in our units but many are already in the field and that’s a headache to update.

I can get around it for the time being.

Thanks again for your help.


That definitely sounds frustrating Leon. When I get a chance, I’ll take a look at the HC-06 and see if there is a work-around and I’ll let you know when I find.