Core Electronics Forum

How to pair microBit with Bluetooth?

Good morning,

Hoping you are well. We are not succeeding in pairing Bluetooth with our microBit. We have used two phones and a Galaxy S6 Lite tablet. The microBit does not appear as an “Available device.”

We have walked through this process several times. It seemed quite foolproof:

Can you provide a link or simple steps to link Bluetooth with the microBit please?

I also think such basic instructions need to be in the box with the kit.

Looking forward to your response. Have a great weekend.

Kind regrards,

William

Have you tried following the microbit instructions?

We went through the sequence once after a few trials, and the microBit didn’t connect when we restarted. Even after it said it was paired.

Every time we tried following that episode and it looks OK but never stops/prompts for the PASSCODE.

These are both Samsung machines. It seems that we are supposed to use the Samsung app, is that right? Ah just re-checked that link. YES, that is exactly the app we are using.

w.

1 Like

What specifically have you tried to get it to work? What elements have you confirmed are working correctly (by testing them with other known good hardware)?

There must be something different about what you’re doing compared to everyone else and the only way to find it will be to be very methodical

Hi Oliver,

Yes I agree. We have worked through the sequence of steps many times with two different Samsung devices.

  • Tablet SM-P610 – Galaxy Tab S6 Lite
  • Phone SM-A705YN – Galaxy A70

With both devices, the outcome and steps are the same. We get to the point where I should enter a code number from the microBit in the app. The microBit show a success image and the app says “Paired”.

However the phone won’t connect after rebooting. What we are not doing is entering a code because no code is shown.

Is there a way to independently connect via bluetooth without using this app? Just as some kind of smoke test, to confirm that it is working properly.

Another thought was that something might have remained “connected” during one of the failing attempts in memory. Is there a setp to perform a “factory reset” and wipe all state? Is there a different way to get the microBit started – Say from a PC or something?

I have bluetooth on my PC but I don’t have an app to use. If someone know of an app or program to connect that would be very good non-Samsung device to test with.

Open to sugggestions, the steps to get this to work do not seem complicated.

Many thanks for checking-in.

Kind regards,

William

Hey William,

This tutorial may have some more information on setting this up for you that was missed on the other page. I suspect that there’s some type of issue with the application, although it’s hard to tell without doing some troubleshooting against each point of failure and with a control. Do you have another microBit board that you can connect to with your devices to confirm that the issue is recurring? If not, I’d recommend updating the application, forgetting the bluetooth connection from your devices, and then reconnecting to see whether the same problem occurs.

2 Likes