How to test SSD in Argon Expansion Board


I have an SSD and an Argon expansion board. I was running Umbrel and had dowloaded the blockchain on the SSD. It was only running for a week or two (totally fine) before I had to reformat the pi and start again.

And then the SSD wouldn’t come back online. How can I test the drive or board?

Many thanks :slight_smile:

Hi Tom,

Welcome to the forum :slight_smile:

When you say you reformatted the Pi, was the OS also running on the SSD, or was it on an SD card with the SSD for extra storage? How the SSD is formatted will determine if the operating system running on the Pi will be able to recognise it.

One test to validate the hardware would be to insert the SSD into another computer and see if the drive can be recognised and what partitions are currently written on it.
I’ve found some guides that cover prepping an SSD to be used with Raspberry Pi OS and how to configure the partition which I’ll link below.


The SSD was formatted automatically by Umbrel as storage. The o/s was on the SD card.

If I take the expansion board off and keep the drive in it, can I just plug it into my mac via the USB and it will turn up in the disk utility?

Hi Tom,

It should show up as a disk at the very least, and depending on the format picked by Umbrel, you may even be able to read it.

If you continue to have problems, perhaps flashing the disk with the Pi imager will allow the pi to boot (if this is where the problem lies)

1 Like

Thanks guys. I can’t get it to show up at all - on my mac, ubuntu box or the pi. Not sure if the problem is the board or the drive. Probably the drive huh? I don’t have another enclosure to test it in…pita.

Hi Tom,

Luckily for me my Umbrel installed, downloaded the blockchain in a week, and has been running for the best part of a year without hiccup. Similar setup I think: RPi4 in Argon One case with a M.2 1TB Samsung SDD.

Can you see your Umbrel via SSH? ie, using: ssh umbrel@umbrel.local then enter your password.
If so, try: sudo fdisk -l
My SSD appears at the bottom of the list, after all of the "/dev/ram#', which must be the SD card, I get two ‘disks’ from the SSD:
the first is: /dev/mmcblk0 which look like FAT32 and linux boot partitions - my guess, not sure.
the second is: /dev/sda1 which is of type: linux filessystem of 931GB - so that’s clearly where the blockchain is stored.

If they don’t appear - can’t be something as simple as the USB connector on the back of the case not fully pushed in can it?

I hope this helps. Cheers, Dave
Afterthought: I referred to using ssh instead of terminal because my unit is headless - assuming you have similar.

1 Like

Ahh, thanks Dave. Sadly I’ve tried the fdisk a few times and it just doesn’t show. I’ve also plugged it in via different cables/connectors too. Making me think I’ve got a problem with the drive or the expansion board…

Have you tried testing the Pi’s USB port with some other peripheral (the middle one in the stack of three), to make sure it’s not the Pi’s (… a bit of a long shot I guess)?
Any way of testing the SSD with another Pi or some other device through the bottom USB?
If it is the expansion board, then hopefully the SSD will be fine and it won’t take another week to resynchronize.
What a pain!

1 Like