Issue with plasma 2040 and RGB LED strip

Hi everyone,

I’ve been trying to test an addressable LED strip I bought recently and I’ve run into an issue I’m not sure how to fix. I followed this guide Getting Started with Plasma 2040 to get set up.

When connected to my plasma 2040 controller I get series of chaotic rainbow effects that don’t match the programming, although they do change character slightly with changes to the code.

I tried changing the RGB order and fiddling with whatever else I could. I also tried adding a 220 ohm resistor to the data line.
Then I noticed that I can greatly affect the intensity of the chaotic rainbow just by touching the power supply case without touching or being near to the data line. When I disconnected the data line from the controller, I could power up the LEDs just by touching the data cable and gently touching the power supply case.

This suggests to me that my original issue could be interference from the power supply getting into the data line, but I’m not sure how that is possible. My wiring is clean and straight forward. I can only think there is some kind of fault in one of my components.

Here are the parts I’ve used.
LEDS:

Power supply:

Controller:

2 Likes

Welcome to the forum, Daniel.

My experience is not with the Plasma, but only with the WS2812, level shifter and Raspberry Pi. I had somewhat similar, but not a full rainbow, as soon as I connected the LED strip.
It proved to be a faulty strip. With another strip, it would work only when I touch the LEDs or the resistor on the strip, which also proved to be faulty.

Typically, the programmable LED strips must not show any color when connected, without any data sent in. I am not familiar with the Plasma controller, so I cannot speak about it.

2 Likes

Thanks G.
I’ve tested with my multimeter and when plugged in to the power supply only, I’m seeing 4V across ground and data. I think that confirms the LED strip is faulty as the data line appears to be shorted with power. I suppose the chaotic colours and patterns would be the strip interpreting fluctuations in power as a signal.
What’s Core’s policy in regards to faulty parts?

2 Likes

Hi Daniel,

Without a video, it’s hard to say, but I ran into what I think is your issue when assembling a printer with APA102 strips. Moving the wires leading to the strip towards the frame of my printer (earthed aluminium extrusion) caused the effect to go away. if you can try something similar, it might improve things a little.

-James

2 Likes

An update to this: With the LED strip connected only to the plasma 2040 for power I’m able to run my programming without any issues. The strip appears to be working as expected.

Since my previous theories have been blown out of the water, my suspicions now fall to the power supply. Any ideas as to why this would happen?

2 Likes

Hi Daniel, Just had the opportunity to read the Pimoroni documentation. It says to connect (power up) the LED’s through the Plasma module. Since you have only an 1 meter strip, the USB-C power is enough.

I do not know how you were connecting the Mean well power supply, it would help with a photo or a schematic (even hand drawn) to determine what is the issue. Typically, when an external power supply is used along with the powered Plasma (or any electronic device of this type), the ground from the external power supply needs to be connected to one of the ground “GPIO” terminals. It provides the reference “zero” for the circuitry. May be it is the cause. But, if everything is working fine, don’t trouble trouble, unless it troubles you.

2 Likes

Ultimately I was planning to have 5 meters of strip controlled by the plasma, so I definitely need the power supplies.
A simple schematic to show what I was trying to do: (Without the dotted line)
Schematic1
So you’re saying I need to have a connection from ground follow the dotted line to the plasma.
Which pin would I need to connect to? Any chance I could have a link to that documentation?
Thanks.

2 Likes

The photo is from the Core product page. You can connect the ground to any of the GND pins.
Or you can just connect to the negative of the JST pin (white wire I guess).

Someone from Core who is more familiar with the Plasma can help you further.

2 Likes

Yes !!!

Have had similar problems on other circuits by not providing a ground reference for the data line.
All you have described fits perfectly into not having the ground connection.

Floating grounds are the bane of a lot of electronics.

Regards
Jim

4 Likes

I’ve connected the ground and now everything appears to be working properly. Thanks for the help guys.

4 Likes