LM311 Minimum signal strength

Hi all…
I am building a line tracker for my son. All went well on the prototype board and I have now soldered it all up. The circuit works fine except that when I centre/balance the comparator voltage, rather than both motors running…neither runs. The circuit uses two LM311 comparators who receive their signal via a 5k pot linked to two LDR (CDS cells ) lines running to ground. It seems their is a minimum level of light needed to activate the circuit and I don’t see why. I can upload a schematic if necessary but any help would be much appreciated…I was hoping to have the bot built by Christmas…

Yes, schematic would be awesome.
Did the weird behaviour start when you soldered it up or was it there on the prototype too?

Only on the finished boards…prototype worked fine. I will upload schematic when I get home from work…maybe a video of the situation too if I can! Thanks so much for the swift response.

If it worked in prototype but not once soldered my guess would be that there may be a “dry joint” somewhere. If you have a close look at all the joints and if any look a bit dull resolder those joints and it may come good.

So I am still working on the schematic…I had an old copy of ISIS (Proteus) which I haven’t used for years and it now longer works so I downloaded a new program…taught myself to use it…drew the schematic and accidentally deleted it…haha.
Anyway…I put all the boards together last night and it works fine with a white paper background but not on anything else. I wired in some ultra-bright white leds and got response on a light brown table top…no dry joins. It seems that when the LDR resistance is high then the LM311 aren’t recognising any signal even if the difference between the two channels is significant??
Anyway I realise without a schematic this probably makes little sense so I will get one posted asap.
Thanks again for your responses.

Hi there…so I finally got the schematic drawn up …here it is…

…the problem is that when the trimpot providing signal to the LM311’s is centred then they neither (rather than both) is sending output signal (and in low light no response at all). On the prototype board I could centre the pot and get both outputs (two sets of LEDs and two motors) going simultaneously.


Hi Roger,

Your schematic looks fine to me, I have to agree that you must have a bad connection somewhere. Start by checking your power and ground. Since its effecting both motors its most likely a break in the line somewhere common to both paths.